summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-02-16 19:33:07 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-02-16 19:33:07 +0000
commita6cefe4ab7f5f0588065e2cc232d0c6cf378192e (patch)
treea28aab1eee1080ce05c95972ab6b8db52181a6b6 /net-dns/dnsmasq
parentApply fixes for Gentoo Prefix, bug 353578 by Dan Wallis (diff)
downloadgentoo-2-a6cefe4ab7f5f0588065e2cc232d0c6cf378192e.tar.gz
gentoo-2-a6cefe4ab7f5f0588065e2cc232d0c6cf378192e.tar.bz2
gentoo-2-a6cefe4ab7f5f0588065e2cc232d0c6cf378192e.zip
Version bump.
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/ChangeLog9
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.52.ebuild4
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.55.ebuild4
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.56.ebuild73
4 files changed, 84 insertions, 6 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 0f933a5147fa..e0ffa0f4b269 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.199 2010/11/19 16:04:20 chutzpah Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.200 2011/02/16 19:33:07 chutzpah Exp $
+
+*dnsmasq-2.56 (16 Feb 2011)
+
+ 16 Feb 2011; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.56.ebuild:
+ Version bump.
19 Nov 2010; Patrick McLean <chutzpah@gentoo.org> files/dnsmasq-init:
Add "use logger" to init script as dnsmasq fails to stop if no logger is
diff --git a/net-dns/dnsmasq/dnsmasq-2.52.ebuild b/net-dns/dnsmasq/dnsmasq-2.52.ebuild
index 741b1f707048..d016ea085129 100644
--- a/net-dns/dnsmasq/dnsmasq-2.52.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.52.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.52.ebuild,v 1.7 2010/05/24 18:53:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.52.ebuild,v 1.8 2011/02/16 19:33:07 chutzpah Exp $
EAPI=2
diff --git a/net-dns/dnsmasq/dnsmasq-2.55.ebuild b/net-dns/dnsmasq/dnsmasq-2.55.ebuild
index 7435753d8dc4..5dcb02cf3922 100644
--- a/net-dns/dnsmasq/dnsmasq-2.55.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.55.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.55.ebuild,v 1.2 2010/10/25 07:52:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.55.ebuild,v 1.3 2011/02/16 19:33:07 chutzpah Exp $
EAPI=2
diff --git a/net-dns/dnsmasq/dnsmasq-2.56.ebuild b/net-dns/dnsmasq/dnsmasq-2.56.ebuild
new file mode 100644
index 000000000000..e6874062a4fd
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.56.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.56.ebuild,v 1.1 2011/02/16 19:33:07 chutzpah Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="dbus +dhcp ipv6 nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ nls? (
+ sys-devel/gettext
+ net-dns/libidn
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ sed -i '/^AWK/s:nawk:gawk:' Makefile #214865
+
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
+}
+
+src_configure() {
+ use tftp || append-flags -DNO_TFTP
+ use dhcp || append-flags -DNO_DHCP
+ use ipv6 || append-flags -DNO_IPV6
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+}
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ all$(use nls && echo "-i18n") || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n") || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}