summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-04 10:29:38 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-04 10:29:38 +0000
commit770affcee60c5c2809ff507d73ec255f32d24c26 (patch)
treefdc80da449188dac6ab3fbf89a8f9f8a089ddbce /sci-chemistry
parentFix compilation, bug #398617 by Marcin Kowalski. (diff)
downloadgentoo-2-770affcee60c5c2809ff507d73ec255f32d24c26.tar.gz
gentoo-2-770affcee60c5c2809ff507d73ec255f32d24c26.tar.bz2
gentoo-2-770affcee60c5c2809ff507d73ec255f32d24c26.zip
Import Version Bump from sci overlay prepared by Reinis Danne; restrict pypy
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog11
-rw-r--r--sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch15
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild6
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.1.ebuild52
4 files changed, 79 insertions, 5 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index 25ff49982d62..473ee2d91087 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/openbabel-python
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.7 2011/09/14 05:06:41 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.8 2012/03/04 10:29:38 jlec Exp $
+
+*openbabel-python-2.3.1 (04 Mar 2012)
+
+ 04 Mar 2012; Justin Lecher <jlec@gentoo.org> openbabel-python-2.3.0.ebuild,
+ +openbabel-python-2.3.1.ebuild,
+ +files/openbabel-python-2.3.1-system_openbabel.patch:
+ Import Version Bump from sci overlay prepared by Reinis Danne; restrict pypy
14 Sep 2011; Justin Lecher <jlec@gentoo.org> openbabel-python-2.3.0.ebuild:
Corrected the right variable (DISTUTILS_SETUP_FILES) to an array, revert the
diff --git a/sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch
new file mode 100644
index 000000000000..6420bba11e8a
--- /dev/null
+++ b/sci-chemistry/openbabel-python/files/openbabel-python-2.3.1-system_openbabel.patch
@@ -0,0 +1,15 @@
+--- scripts/python/setup.py
++++ scripts/python/setup.py
+@@ -15,11 +15,7 @@
+
+ obExtension = Extension('_openbabel',
+ [os.path.join(srcdir, "openbabel-python.cpp")],
+- include_dirs=[os.path.join(srcdir, "..", "..", "include"),
+- os.path.join("..", "include")],
+- library_dirs=[os.path.join(srcdir, "..", "..", "lib"),
+- os.path.join(srcdir, "..", "..", "lib64"),
+- os.path.join("..", "lib")],
++ include_dirs=[os.path.join("/usr", "include", "openbabel-2.0")],
+ libraries=['openbabel']
+ )
+
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
index 04d5a8390a13..3c5a927136cf 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.7 2011/09/14 05:06:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.0.ebuild,v 1.8 2012/03/04 10:29:38 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
PYTHON_MODNAME="openbabel.py pybel.py"
inherit distutils eutils
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.1.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.1.ebuild
new file mode 100644
index 000000000000..099307fcebe3
--- /dev/null
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.1.ebuild,v 1.1 2012/03/04 10:29:38 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+PYTHON_MODNAME="openbabel.py pybel.py"
+
+inherit distutils eutils flag-o-matic
+
+DESCRIPTION="Python bindings for OpenBabel (including Pybel)"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/openbabel-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/eigen:2
+ dev-libs/libxml2:2
+ !sci-chemistry/babel
+ ~sci-chemistry/openbabel-${PV}
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-2"
+
+S="${WORKDIR}"/openbabel-${PV}
+
+DISTUTILS_SETUP_FILES=("scripts|python/setup.py")
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-system_openbabel.patch
+
+ sed \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -i ./scripts/python/setup.py || die
+
+ swig -python -c++ -small -O -templatereduce -naturalvar \
+ -I"${EPREFIX}/usr/include/openbabel-2.0" \
+ -o scripts/python/openbabel-python.cpp \
+ -DHAVE_EIGEN2 \
+ -outdir scripts/python \
+ scripts/openbabel-python.i \
+ || die "Regeneration of openbabel-python.cpp failed"
+
+ append-cxxflags "$(pkg-config --cflags-only-I eigen2)"
+}