summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-02-28 14:04:31 +0000
committerSlawek Lis <slis@gentoo.org>2014-02-28 14:04:31 +0000
commit79bdb16dca86924950e658158de0e9db547a4e95 (patch)
tree279a0c7a97ad69f94029f396abb1cad49e7cbddf /sci-libs/Shapely
parentVersion bump. (diff)
downloadgentoo-2-79bdb16dca86924950e658158de0e9db547a4e95.tar.gz
gentoo-2-79bdb16dca86924950e658158de0e9db547a4e95.tar.bz2
gentoo-2-79bdb16dca86924950e658158de0e9db547a4e95.zip
Added Shapely package
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/ChangeLog10
-rw-r--r--sci-libs/Shapely/Manifest4
-rw-r--r--sci-libs/Shapely/Shapely-1.3.0.ebuild33
-rw-r--r--sci-libs/Shapely/Shapely-9999.ebuild33
-rw-r--r--sci-libs/Shapely/metadata.xml7
5 files changed, 87 insertions, 0 deletions
diff --git a/sci-libs/Shapely/ChangeLog b/sci-libs/Shapely/ChangeLog
new file mode 100644
index 000000000000..78fc544faa8c
--- /dev/null
+++ b/sci-libs/Shapely/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/Shapely
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.1 2014/02/28 14:04:31 slis Exp $
+
+*Shapely-1.3.0 (28 Feb 2014)
+*Shapely-9999 (28 Feb 2014)
+
+ 28 Feb 2014; Sławek Lis <slis@gentoo.org> +Shapely-1.3.0.ebuild,
+ +Shapely-9999.ebuild, +metadata.xml:
+ Added Shapely package
diff --git a/sci-libs/Shapely/Manifest b/sci-libs/Shapely/Manifest
new file mode 100644
index 000000000000..615cca1b796b
--- /dev/null
+++ b/sci-libs/Shapely/Manifest
@@ -0,0 +1,4 @@
+DIST Shapely-1.3.0.tar.gz 118863 SHA256 297df004aec27e38ed93987e93ff5f8187cd0299394fe8b0b9028566015a9bb5 SHA512 106f9773a5b00e7269a84c760f3a2b867c48139c48eebeecd524c8216d75c28daaf46eff45c118c1809999e33a317e9aca278a8d83605dc7273877a7ed3edd82 WHIRLPOOL ddf42cab233b0950a4a955070c5a2a7791a7f259ba857778689944c7799484f7c1aa710926c37c8c66deaae5ab4f03d79fa2f407e8e6d05238217b529e7b1b15
+EBUILD Shapely-1.3.0.ebuild 718 SHA256 306b1e563735517bae86c1e7f51fac384679aa5919d07cb45a2721df3198854d SHA512 d2543dc0a9d1a4bb8196bfbc2250fdd0849055e62461f70a31beadabb8cbdbfd2179a668fc10f836d1fb624d7d42a6f8f8bd5037398f509526fd389d0bbd2dea WHIRLPOOL 20f5af0705068522fa47b37a7300d8859881dcc5e2015288ec0e034f68f59bc242ba47f0c2d7dfff87f0ab83aab3965b4aeac28144fafd903780f48c33f4925b
+EBUILD Shapely-9999.ebuild 718 SHA256 306b1e563735517bae86c1e7f51fac384679aa5919d07cb45a2721df3198854d SHA512 d2543dc0a9d1a4bb8196bfbc2250fdd0849055e62461f70a31beadabb8cbdbfd2179a668fc10f836d1fb624d7d42a6f8f8bd5037398f509526fd389d0bbd2dea WHIRLPOOL 20f5af0705068522fa47b37a7300d8859881dcc5e2015288ec0e034f68f59bc242ba47f0c2d7dfff87f0ab83aab3965b4aeac28144fafd903780f48c33f4925b
+MISC metadata.xml 205 SHA256 132e3db1188fcdf8aa6467bde8677e24fc63015666de6104a656a5b074932454 SHA512 e53c51c47b6f2ba5302d5fe6ee9524fe49c69d2b03d66aa0a3054185c7c0a83dedeec75ea15424afe22f1423d72c5bbc1c1e07c6bdbdd1912d8eb8e046a4ef58 WHIRLPOOL 5f4c6dfd2f9dae15971877f2eb53c1d9f6196a42dc62b2d95ffd2060f119d7e0794541b3d8ca565f9ca48479325d19864f74a85289c83d5a5e2396f9144d161c
diff --git a/sci-libs/Shapely/Shapely-1.3.0.ebuild b/sci-libs/Shapely/Shapely-1.3.0.ebuild
new file mode 100644
index 000000000000..814952569578
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.0.ebuild,v 1.1 2014/02/28 14:04:31 slis Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+} \ No newline at end of file
diff --git a/sci-libs/Shapely/Shapely-9999.ebuild b/sci-libs/Shapely/Shapely-9999.ebuild
new file mode 100644
index 000000000000..25103dd00085
--- /dev/null
+++ b/sci-libs/Shapely/Shapely-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-9999.ebuild,v 1.1 2014/02/28 14:04:31 slis Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="https://pypi.python.org/pypi/Shapely"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/geos-3.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+} \ No newline at end of file
diff --git a/sci-libs/Shapely/metadata.xml b/sci-libs/Shapely/metadata.xml
new file mode 100644
index 000000000000..1847f17d2266
--- /dev/null
+++ b/sci-libs/Shapely/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>