summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-09 10:17:48 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-09 10:17:48 +0000
commit6b8f78651c425f6d6ec8b68e05149735543853f1 (patch)
tree5985c9379926633fae9415b233c85aa3ee75288b /www-plugins
parentInitial commit wrt #97640, thanks to Vic Fryzel for reporting. (diff)
downloadgentoo-2-6b8f78651c425f6d6ec8b68e05149735543853f1.tar.gz
gentoo-2-6b8f78651c425f6d6ec8b68e05149735543853f1.tar.bz2
gentoo-2-6b8f78651c425f6d6ec8b68e05149735543853f1.zip
Fix bug #284244, src_install() always failed with USE=-nsplugin due to a stupid test line 184, replace it by an if
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/ChangeLog7
-rw-r--r--www-plugins/gnash/gnash-0.8.5.ebuild11
2 files changed, 13 insertions, 5 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 769370534d04..00c11fe3c004 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.7 2009/09/08 21:22:34 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.8 2009/09/09 10:17:48 mrpouet Exp $
+
+ 09 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ gnash-0.8.5.ebuild:
+ Fix bug #284244, src_install() always failed with USE=-nsplugin due to
+ stupid test line 184, replace it by an if.
08 Sep 2009; Romain Perier <mrpouet@gentoo.org>
gnash-0.8.5.ebuild, +files/gnash-0.8.5-klash.patch,
diff --git a/www-plugins/gnash/gnash-0.8.5.ebuild b/www-plugins/gnash/gnash-0.8.5.ebuild
index 2b73d87ea1f7..d35248afbdeb 100644
--- a/www-plugins/gnash/gnash-0.8.5.ebuild
+++ b/www-plugins/gnash/gnash-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.3 2009/09/08 21:20:23 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.4 2009/09/09 10:17:48 mrpouet Exp $
EAPI="2"
KDE_REQUIRED="optional"
@@ -118,7 +118,7 @@ src_prepare() {
eautoreconf
}
src_configure() {
- local myconf jobs
+ local myconf
local gui="sdl"
# Set nsplugin install directory.
use nsplugin && myconf="${myconf} --with-npapi-plugindir=/opt/netscape/plugins"
@@ -179,9 +179,12 @@ src_configure() {
${myconf}
}
src_install() {
- emake ${jobs} DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
+
# Install nsplugin in directory set by --with-npapi-plugindir.
- use nsplugin && emake DESTDIR="${D}" install-plugin || die "install plugins failed"
+ if use nsplugin; then
+ emake DESTDIR="${D}" install-plugin || die "install plugins failed"
+ fi
# Install kde konqueror plugin.
if use kde; then