summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-04 13:59:09 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-04 13:59:09 +0000
commit033b01b4d062e91b6098322f3be0bd7e409b017c (patch)
tree403feaa3f6a9262ad960bdb497138d24b150f138 /x11-terms/xvt
parentremoved the patch. (diff)
downloadgentoo-2-033b01b4d062e91b6098322f3be0bd7e409b017c.tar.gz
gentoo-2-033b01b4d062e91b6098322f3be0bd7e409b017c.tar.bz2
gentoo-2-033b01b4d062e91b6098322f3be0bd7e409b017c.zip
Turn seds into patches. Respect CFLAGS (bug #241554), CC.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'x11-terms/xvt')
-rw-r--r--x11-terms/xvt/ChangeLog10
-rw-r--r--x11-terms/xvt/files/xvt-int-main.patch23
-rw-r--r--x11-terms/xvt/files/xvt-makefile.patch20
-rw-r--r--x11-terms/xvt/xvt-2.1-r2.ebuild45
4 files changed, 96 insertions, 2 deletions
diff --git a/x11-terms/xvt/ChangeLog b/x11-terms/xvt/ChangeLog
index b62666147f38..7e0cfea66219 100644
--- a/x11-terms/xvt/ChangeLog
+++ b/x11-terms/xvt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/xvt
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xvt/ChangeLog,v 1.14 2008/03/27 01:50:15 rbu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xvt/ChangeLog,v 1.15 2009/09/04 13:59:09 jer Exp $
+
+*xvt-2.1-r2 (04 Sep 2009)
+
+ 04 Sep 2009; Jeroen Roovers <jer@gentoo.org> +xvt-2.1-r2.ebuild,
+ +files/xvt-int-main.patch, +files/xvt-makefile.patch:
+ Turn seds into patches. Respect CFLAGS (bug #241554), CC.
27 Mar 2008; Robert Buchholz <rbu@gentoo.org> xvt-2.1-r1.ebuild:
adding ~amd64
diff --git a/x11-terms/xvt/files/xvt-int-main.patch b/x11-terms/xvt/files/xvt-int-main.patch
new file mode 100644
index 000000000000..81baa76ce5e0
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-int-main.patch
@@ -0,0 +1,23 @@
+--- xvt-1.0/xvt.c.orig 2009-09-04 15:49:13.000000000 +0200
++++ xvt-1.0/xvt.c 2009-09-04 15:49:13.000000000 +0200
+@@ -41,9 +41,9 @@
+ #endif /* UKC_LOCATIONS */
+
+ #ifdef __STDC__
+-void main(int,char **);
++int main(int,char **);
+ #else
+-void main();
++int main();
+ #endif
+
+ extern int debugging;
+@@ -67,7 +67,7 @@
+ * master end of the pseudo-teletype pair with the command talking to
+ * the slave.
+ */
+-void
++int
+ main(argc,argv)
+ int argc;
+ char **argv;
diff --git a/x11-terms/xvt/files/xvt-makefile.patch b/x11-terms/xvt/files/xvt-makefile.patch
new file mode 100644
index 000000000000..368fdeeb00be
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-makefile.patch
@@ -0,0 +1,20 @@
+--- xvt-1.0/Makefile.orig 2009-09-04 15:45:08.000000000 +0200
++++ xvt-1.0/Makefile 2009-09-04 15:46:00.000000000 +0200
+@@ -27,7 +27,7 @@
+ #ARCH=AIX3
+ #ARCH=ULTRIX
+ #ARCH=HPUX
+-#ARCH=LINUX
++ARCH=LINUX
+ #
+ #
+ # If this line is uncommented then `Make config' will unclude several options
+@@ -107,7 +107,7 @@
+ OBJ=xvt.o xsetup.o command.o screen.o sbar.o ttyinit.o
+ SRC=xvt.c xsetup.c command.c screen.c sbar.c ttyinit.c
+ #
+-CFLAGS=-O $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
++CFLAGS+= $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
+ #
+ xvt: $(OBJ)
+ $(CC) $(LDFLAGS) -o xvt $(OBJ) $(LIB) -lX11
diff --git a/x11-terms/xvt/xvt-2.1-r2.ebuild b/x11-terms/xvt/xvt-2.1-r2.ebuild
new file mode 100644
index 000000000000..2d96bf3b4eb9
--- /dev/null
+++ b/x11-terms/xvt/xvt-2.1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xvt/xvt-2.1-r2.ebuild,v 1.1 2009/09/04 13:59:09 jer Exp $
+
+EAPI="2"
+
+inherit ccc eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A tiny vt100 terminal emulator for X"
+HOMEPAGE="ftp://ftp.x.org/R5contrib/xvt-1.0.README"
+SRC_URI="ftp://ftp.x.org/R5contrib/xvt-1.0.tar.Z
+ mirror://gentoo/xvt-2.1.diff.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+S=${WORKDIR}/${PN}-1.0
+
+src_prepare() {
+ # this brings the distribution upto version 2.1
+ epatch "${WORKDIR}"/xvt-2.1.diff
+
+ # fix #61393
+ epatch "${FILESDIR}/xvt-ttyinit-svr4pty.diff"
+
+ # CFLAGS, CC #241554
+ epatch "${FILESDIR}/xvt-makefile.patch"
+
+ # int main, not void main
+ epatch "${FILESDIR}/xvt-int-main.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xvt || die "dobin failed"
+ doman xvt.1
+ dodoc README
+}