summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/dclib/ChangeLog7
-rw-r--r--net-p2p/dclib/dclib-0.1.ebuild28
-rw-r--r--net-p2p/dclib/files/digest-dclib-0.11
-rw-r--r--net-p2p/qt-dcgui/ChangeLog7
-rw-r--r--net-p2p/qt-dcgui/files/digest-qt-dcgui-0.11
-rw-r--r--net-p2p/qt-dcgui/qt-dcgui-0.1.ebuild30
6 files changed, 72 insertions, 2 deletions
diff --git a/net-p2p/dclib/ChangeLog b/net-p2p/dclib/ChangeLog
index 24522cdff440..80b1d67bfef7 100644
--- a/net-p2p/dclib/ChangeLog
+++ b/net-p2p/dclib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/dclib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.2 2002/10/02 23:36:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/ChangeLog,v 1.3 2002/10/07 17:33:40 vapier Exp $
+
+*dclib-0.1 (07 Oct 2002)
+
+ 02 Oct 2002; Mike Frysinger <vapier@gentoo.org> dclib-0.1.ebuild :
+ Updated to the 0.1 release, that is all #8837
*dclib-0.1_rc2 (02 Oct 2002)
diff --git a/net-p2p/dclib/dclib-0.1.ebuild b/net-p2p/dclib/dclib-0.1.ebuild
new file mode 100644
index 000000000000..558efbd34d4e
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.1.ebuild,v 1.1 2002/10/07 17:33:41 vapier Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Library for the Qt client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://dc.ketelhot.de/files/dcgui/stable/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND=">=sys-apps/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export CPPFLAGS="${CXXFLAGS} -I/usr/include/libxml2/libxml"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}
diff --git a/net-p2p/dclib/files/digest-dclib-0.1 b/net-p2p/dclib/files/digest-dclib-0.1
new file mode 100644
index 000000000000..16ddce312337
--- /dev/null
+++ b/net-p2p/dclib/files/digest-dclib-0.1
@@ -0,0 +1 @@
+MD5 57636e087a226af6be1691234d964828 dclib-0.1.tar.bz2 399114
diff --git a/net-p2p/qt-dcgui/ChangeLog b/net-p2p/qt-dcgui/ChangeLog
index 4d91ad31e6af..ec005d650fa6 100644
--- a/net-p2p/qt-dcgui/ChangeLog
+++ b/net-p2p/qt-dcgui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qt-dcgui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/ChangeLog,v 1.2 2002/10/02 23:37:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/ChangeLog,v 1.3 2002/10/07 17:33:28 vapier Exp $
+
+*qt-dcgui-0.1 (07 Oct 2002)
+
+ 02 Oct 2002; Mike Frysinger <vapier@gentoo.org> qt-dcgui-0.1.ebuild :
+ Version bump #8837
*qt-dcgui-0.1_rc2 (02 Oct 2002)
diff --git a/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.1 b/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.1
new file mode 100644
index 000000000000..85b0ee7f2806
--- /dev/null
+++ b/net-p2p/qt-dcgui/files/digest-qt-dcgui-0.1
@@ -0,0 +1 @@
+MD5 c5d3f9d1d0e654981232743735ceb26a dcgui-0.1.tar.bz2 482170
diff --git a/net-p2p/qt-dcgui/qt-dcgui-0.1.ebuild b/net-p2p/qt-dcgui/qt-dcgui-0.1.ebuild
new file mode 100644
index 000000000000..0779a0a6b45f
--- /dev/null
+++ b/net-p2p/qt-dcgui/qt-dcgui-0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/qt-dcgui-0.1.ebuild,v 1.1 2002/10/07 17:33:28 vapier Exp $
+
+MY_P=${P/qt-/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Qt based client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://dc.ketelhot.de/files/dcgui/stable/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/qt-3*
+ >=dev-libs/libxml2-2.4.22
+ =net-p2p/dclib-${PV}"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export CPPFLAGS="${CXXFLAGS} -I/usr/include/libxml2/libxml"
+
+ econf --with-libdc=/usr || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}