summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/dclib/dclib-0.1.ebuild')
-rw-r--r--net-p2p/dclib/dclib-0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-p2p/dclib/dclib-0.1.ebuild b/net-p2p/dclib/dclib-0.1.ebuild
new file mode 100644
index 000000000000..558efbd34d4e
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.1.ebuild,v 1.1 2002/10/07 17:33:41 vapier Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Library for the Qt client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://dc.ketelhot.de/files/dcgui/stable/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND=">=sys-apps/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ export CPPFLAGS="${CXXFLAGS} -I/usr/include/libxml2/libxml"
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}