summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/silo/ChangeLog7
-rw-r--r--sys-boot/silo/files/digest-silo-1.4.133
-rw-r--r--sys-boot/silo/silo-1.4.13.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 3f253e737560..80bc151ed6e2 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.30 2006/06/19 20:43:38 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.31 2006/06/23 18:50:34 gustavoz Exp $
+
+*silo-1.4.13 (23 Jun 2006)
+
+ 23 Jun 2006; Gustavo Zacarias <gustavoz@gentoo.org> +silo-1.4.13.ebuild:
+ Revbump
*silo-1.4.12-r1 (19 Jun 2006)
diff --git a/sys-boot/silo/files/digest-silo-1.4.13 b/sys-boot/silo/files/digest-silo-1.4.13
new file mode 100644
index 000000000000..aee9a7d8f69e
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.4.13
@@ -0,0 +1,3 @@
+MD5 661c806cca8a1bf076fe30f8c7ed29be silo-1.4.13.tar.gz 168934
+RMD160 7bf47998de80e9f1efc330aaef7a00ca51b0d1a0 silo-1.4.13.tar.gz 168934
+SHA256 a6bc12c3b82d9e1b717e706a068274696914b798b79bdde198b2ed93ab079189 silo-1.4.13.tar.gz 168934
diff --git a/sys-boot/silo/silo-1.4.13.ebuild b/sys-boot/silo/silo-1.4.13.ebuild
new file mode 100644
index 000000000000..1303662ba48a
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13.ebuild,v 1.1 2006/06/23 18:50:34 gustavoz Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}