summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/silo/silo-1.4.13.ebuild')
-rw-r--r--sys-boot/silo/silo-1.4.13.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-boot/silo/silo-1.4.13.ebuild b/sys-boot/silo/silo-1.4.13.ebuild
new file mode 100644
index 000000000000..1303662ba48a
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.13.ebuild,v 1.1 2006/06/23 18:50:34 gustavoz Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}