aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Bersenev <bay@hackerdom.ru>2011-08-21 18:51:39 +0000
committerAlexander Bersenev <bay@hackerdom.ru>2011-08-21 18:51:39 +0000
commita40aeaee9aa2736c837353becab9bb10788b43ab (patch)
tree6d12477980d549ee60d052c0d44d98efa25e637b
parentfirst version of toplevel makefile (diff)
downloadautodep-a40aeaee9aa2736c837353becab9bb10788b43ab.tar.gz
autodep-a40aeaee9aa2736c837353becab9bb10788b43ab.tar.bz2
autodep-a40aeaee9aa2736c837353becab9bb10788b43ab.zip
prepare to emerging
-rw-r--r--Makefile8
-rw-r--r--ebuild/autodep-0.1.ebuild27
-rwxr-xr-xemerge_strict13
-rw-r--r--src/autodep/tests/all_tests.py2
4 files changed, 49 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 96e3763..88d9363 100644
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,14 @@ file_hook.so: file_hook.o
file_hook.o: src/hook_lib/file_hook.c
cc -Wall -fPIC -o file_hook.o -c src/hook_lib/file_hook.c
+install:
+ mkdir -p "${DESTDIR}/usr/lib/"
+ cp file_hook.so "${DESTDIR}/usr/lib/"
+ cp -R src/autodep "${DESTDIR}/usr/lib/"
+ cp -R portage_with_autodep "${DESTDIR}/usr/lib/"
+
+ mkdir -p "${DESTDIR}/usr/bin/"
+ cp hookfs emerge_strict "${DESTDIR}/usr/bin/"
clean:
rm -f hookfs file_hook.o file_hook.so
diff --git a/ebuild/autodep-0.1.ebuild b/ebuild/autodep-0.1.ebuild
new file mode 100644
index 0000000..37ccfa7
--- /dev/null
+++ b/ebuild/autodep-0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND='2:2.6'
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+
+inherit distutils eutils
+
+DESCRIPTION="Auto dependency analyser for Gentoo"
+HOMEPAGE="http://alexbers.dyndns.org/autodep/"
+SRC_URI="http://alexbers.dyndns.org/autodep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/emerge_strict b/emerge_strict
new file mode 100755
index 0000000..ea242b0
--- /dev/null
+++ b/emerge_strict
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# get name of myself
+WRAPPER_NAME="`readlink -f "$0"`"
+PROG_DIR="`dirname "$WRAPPER_NAME"`"
+LIB_DIR="`readlink -f "$PROG_DIR"/../lib`"
+
+export PYTHONPATH="$LIB_DIR/portage_with_autodep/pym:${PYTHONPATH}"
+export PATH="$LIB_DIR/portage_with_autodep/bin:${PATH}"
+
+export FEATURES="depcheckstrict ${FEATURES}"
+
+exec emerge "$@"
diff --git a/src/autodep/tests/all_tests.py b/src/autodep/tests/all_tests.py
index 0d52de7..3542ca8 100644
--- a/src/autodep/tests/all_tests.py
+++ b/src/autodep/tests/all_tests.py
@@ -2,7 +2,7 @@ import glob
import unittest
# change it if you don't want get all tests runned
-testsglob='tests/test_p*.py'
+testsglob='tests/test_*.py'
def create_test_suite():
test_file_strings = glob.glob(testsglob)