summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-02-18 09:30:46 +0100
committerCiaran McCreesh <ciaran.mccreesh@googlemail.com>2009-02-20 16:47:36 +0000
commit70c5dbab3e126f92ed7d9650224bec15feb9ead9 (patch)
tree0c4ecb0c4c6307091fe3f4f1ccb1ee3e978ecc88 /Makefile
parentAdd prefixes to labels. (diff)
downloadpms-70c5dbab3e126f92ed7d9650224bec15feb9ead9.tar.gz
pms-70c5dbab3e126f92ed7d9650224bec15feb9ead9.tar.bz2
pms-70c5dbab3e126f92ed7d9650224bec15feb9ead9.zip
Use date from VC system
Make the \date command aware of the version control system by adding the vc package (public-domain) and thus display date of last commit and not of generation as long as a Git repository is available.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 774fc39..8b49437 100644
--- a/Makefile
+++ b/Makefile
@@ -3,13 +3,13 @@ html : pms.html
clean :
rm -f *~ *.pdf *.dvi *.log *.aux *.bbl *.blg *.toc *.lol *.loa *.lox \
- *.lot *.out *.html *.css *.png *.4ct *.4tc *.idv *.lg *.tmp *.xref || true
+ *.lot *.out *.html *.css *.png *.4ct *.4tc *.idv *.lg *.tmp *.xref vc.tex || true
LATEXFILES = $(shell ls *.tex)
LISTINGFILES = $(shell ls *.listing)
SOURCEFILES = $(LATEXFILES) $(LISTINGFILES)
-pms.pdf: $(SOURCEFILES) pms.bbl
+pms.pdf: $(SOURCEFILES) pms.bbl vc.tex
pdflatex pms
pdflatex pms
pdflatex pms
@@ -27,10 +27,13 @@ pms.html: $(SOURCEFILES) pms.bbl
@# align algorithm line numbers properly
sed -i -e '/<span class="ALCitem">/{N;s/\n\(class="[^"]\+">\)\([0-9]:\)<\/span>/\1\&#x2007;\2/}' pms.html
-pms.bbl: pms.bib pms.tex
+pms.bbl: pms.bib pms.tex vc.tex
latex pms
bibtex pms
+vc.tex: pms.tex
+ /bin/sh ./vc
+
pms.dvi: $(SOURCEFILES) pms.bbl
latex pms
latex pms