aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 13:11:49 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:18 +0200
commit969ba769b7c38e88cc9beca7812599f2c16e70f8 (patch)
tree1a2cd9f3b39ce0c0b25f1072ba33682ae0f7955c
parentsci-physics/hepunits: add 2.3.5 (diff)
downloadsci-969ba769b7c38e88cc9beca7812599f2c16e70f8.tar.gz
sci-969ba769b7c38e88cc9beca7812599f2c16e70f8.tar.bz2
sci-969ba769b7c38e88cc9beca7812599f2c16e70f8.zip
sci-physics/particle: add 0.25.2
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/particle/Manifest1
-rw-r--r--sci-physics/particle/particle-0.25.2.ebuild48
-rw-r--r--sci-physics/particle/particle-9999.ebuild10
3 files changed, 56 insertions, 3 deletions
diff --git a/sci-physics/particle/Manifest b/sci-physics/particle/Manifest
index 2f92c548b..6d914f4f9 100644
--- a/sci-physics/particle/Manifest
+++ b/sci-physics/particle/Manifest
@@ -1,3 +1,4 @@
DIST particle-0.23.0.tar.gz 313512 BLAKE2B 33a0dc1cf612af8242b5080d0862f3b1e587254b46fa90f235cd6edba3919594c5077733600dfe88ad0959be889271c301324789abf0511a7fbe588942086877 SHA512 582c42beade0b28f28f3ee9f83f6d8cc75558f8a9aa5fbe3679c7aa68af40bd04f374741211d6f214bb828c24a017a89b541f780739a36d61d85a2fd5e00b530
DIST particle-0.23.1.tar.gz 313729 BLAKE2B fc35163955e065b350dfa0825612a64214baeb1f5be41404af259136e6689e23419891513c059ccdfbe2cbf5891596fccd0b0b7f283031bb3352600b5be43441 SHA512 1b4f4516357fd9725d9d5b0a481467896e93e23a8956b2ce321b9cac1d200a8ee8dd9cc1b22d940b4708f29abe3417988677ac685b78287abe10afafa79fb381
DIST particle-0.24.0.tar.gz 314302 BLAKE2B bbb2d52a80b4d9aafaf86a3cc1b28106253bf0edfe5a6127c03242a32973feaefeb32562063e5ff0438f5df946a905d03baa36c445093ce185d3be71c10e5135 SHA512 5a73079d9120ab509162189ba5992c615fc00e00d37a6556338130739bbf53fd5db01e973cb1b509ef7ce569021c0462ac77e5fcafe40df31e5cef0a89923a2a
+DIST particle-0.25.2.tar.gz 316882 BLAKE2B def3a11f7396d211ce312473661c25c4ef75b2c7cc5f4394f8ac3c6551674db3ac7308e083401ad29c31d34073e8491da0b6daf26a553a9c64c5757c93c8ac02 SHA512 6ada0742baa82dd85adaf6b281f2573bd6fdaacff655588cec75a6e39a02d3720cb012623690745f2c1a2631da5f54b3882f3461aadd3fd5621f9e15af98807d
diff --git a/sci-physics/particle/particle-0.25.2.ebuild b/sci-physics/particle/particle-0.25.2.ebuild
new file mode 100644
index 000000000..e5e49ea91
--- /dev/null
+++ b/sci-physics/particle/particle-0.25.2.ebuild
@@ -0,0 +1,48 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1
+
+DESCRIPTION="PDG particle data and identification codes"
+HOMEPAGE="https://github.com/scikit-hep/particle"
+
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scikit-hep/particle"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ >=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ ' python3_{11..12})
+
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--benchmark-disable::' pyproject.toml || die
+}
+
+python_test() {
+ epytest --ignore tests/particle/test_performance.py
+}
diff --git a/sci-physics/particle/particle-9999.ebuild b/sci-physics/particle/particle-9999.ebuild
index 43f1e67ca..e5e49ea91 100644
--- a/sci-physics/particle/particle-9999.ebuild
+++ b/sci-physics/particle/particle-9999.ebuild
@@ -1,6 +1,6 @@
EAPI=8
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_{11..13} )
DISTUTILS_USE_PEP517=hatchling
inherit distutils-r1
@@ -22,12 +22,16 @@ RDEPEND="
>=dev-python/attrs-19.2[${PYTHON_USEDEP}]
>=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
dev-python/deprecated[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ ' python3_{11..12})
+
"
-DEPEND="${RDEPEND}"
BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
test? (
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
)
"