aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-19 01:52:12 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-01-19 01:52:12 +0000
commit9630012fc1583022d4d3ec9cc8d6fc714dcd143e (patch)
tree80479d2dd5dd96496a95c405870cd5ca6695ed3d /dev-python
parentsci-libs/arrayfire: version bump to 3.8.0 (diff)
downloadsci-9630012fc1583022d4d3ec9cc8d6fc714dcd143e.tar.gz
sci-9630012fc1583022d4d3ec9cc8d6fc714dcd143e.tar.bz2
sci-9630012fc1583022d4d3ec9cc8d6fc714dcd143e.zip
dev-python/umap-learn: version bump to 0.5.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/umap-learn/Manifest1
-rw-r--r--dev-python/umap-learn/umap-learn-0.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/umap-learn/Manifest b/dev-python/umap-learn/Manifest
index e2525d5c5..fff6ead67 100644
--- a/dev-python/umap-learn/Manifest
+++ b/dev-python/umap-learn/Manifest
@@ -1 +1,2 @@
DIST umap-learn-0.4.6.tar.gz 69894 BLAKE2B 9d2029f31e58e5e0e4b4b32aa8d26f3d8a4a22684e99bb06b623ff35c3e3ed9ac63e532c409c206b95a1d0e2079f8512294e43eb77389351e1145e6a7ba35025 SHA512 9f339ac55bb3e9326dd3b04e71dcdd9e22ea40b0240b62a7af629167eb18b7d5cf11cdfdcb0215cfe54ffe69026b234188c2f81c26f231fed741deeff3daa5e9
+DIST umap-learn-0.5.0.tar.gz 81722 BLAKE2B 9de88cbac480f97b2fee77fca9c43b99417c1ed0be222d92024d67379335ff2c376096b47ab151ffaa18f180a50e7289f6872e6ff03fabdad49c52f7781b1868 SHA512 cd4ccba452d773f1ea9875a35b4e3dc616e34d8707bfbba376964b1606bbf02903f8a6ed8387c77dc88d733c2a2f1bd3bc02908fd43a42441bf9043a1bdd8025
diff --git a/dev-python/umap-learn/umap-learn-0.5.0.ebuild b/dev-python/umap-learn/umap-learn-0.5.0.ebuild
new file mode 100644
index 000000000..37ca3ca45
--- /dev/null
+++ b/dev-python/umap-learn/umap-learn-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Uniform Manifold Approximation and Projection"
+HOMEPAGE="https://umap-learn.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pynndescent[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+# no tests in package