aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-03-13 13:23:59 -0400
committerHorea Christian <chr@chymera.eu>2020-03-13 13:23:59 -0400
commit93db1deef32d195a5ae05947b2eeed8e3e209d7c (patch)
treea9e2f03fb90384f460dae77ec3de8298cf4b3cd2 /sci-libs/pydicom
parentsci-biology/bowtie: version bump (bugfix release) (diff)
downloadsci-93db1deef32d195a5ae05947b2eeed8e3e209d7c.tar.gz
sci-93db1deef32d195a5ae05947b2eeed8e3e209d7c.tar.bz2
sci-93db1deef32d195a5ae05947b2eeed8e3e209d7c.zip
sci-libs/pydicom: version bump 1.4.2
with PYTHON_COMPAT 3_7 bump and test suite fix Package-Manager: Portage-2.3.92, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'sci-libs/pydicom')
-rw-r--r--sci-libs/pydicom/Manifest1
-rw-r--r--sci-libs/pydicom/pydicom-1.4.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/pydicom/Manifest b/sci-libs/pydicom/Manifest
index 18fbb7f9d..7d4695b25 100644
--- a/sci-libs/pydicom/Manifest
+++ b/sci-libs/pydicom/Manifest
@@ -1,2 +1,3 @@
DIST pydicom-0.9.9.tar.gz 422348 BLAKE2B 68ffa180ab926ebce2bd30f8fa6ff2442dfacf0fb2832f179010afda7092e7b4a4cbac2738aff5c7188b04c433b08bc19d64c1c9ebe07ae5dac5cd120e77e92f SHA512 3c2f3af6cc1f4a4a53894f236f55c33658bb448ad71571521fabe5d8b2a0e48b9cfaec491aa6f524cf7bbe294d9a784c5290d31a312ebd26701bacaac8253da7
DIST pydicom-1.1.0.tar.gz 6724086 BLAKE2B efdcdd722bc877b9b9cf137ecd2a3fa6fb2b7da022bdab49f03dbcdb5a3e3dc8bc24b6b0d8eb9ab946934ec182c13ec1df671461c357476f543afb6f435f604c SHA512 ffca9eb4333d29accea1d6e5a5b4c3c0bd0f8c12fdf00c5c84d83769db621e8f348c9200dff1dc1cd6016cbf5d76b00f08c3b112ba653433a84ce31ad1ab33d5
+DIST pydicom-1.4.2.tar.gz 35237997 BLAKE2B 0b4db847150153519cc7d805a9a7b9c5c4d9ed46496bd561a24e5ede1cd3b5f176581a9741aba65c31cdd0533fb6a33905cc21003f0237c7cd7e603ef672c67a SHA512 8fc0a2e5f0a8578b98d49b749912cca98d51bdcae2b3bd5759e03e13cd2a2d4f45ce0e2a22d80526abfa5f428a4a71b5fad2c9f36bafc4f3fa2866cd687ac015
diff --git a/sci-libs/pydicom/pydicom-1.4.2.ebuild b/sci-libs/pydicom/pydicom-1.4.2.ebuild
new file mode 100644
index 000000000..2ab96e750
--- /dev/null
+++ b/sci-libs/pydicom/pydicom-1.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python package for parsing DICOM files"
+HOMEPAGE="http://www.pydicom.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ distutils-r1_install_for_testing
+ py.test -r sx --pyargs pydicom --verbose || die
+}