summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-18 23:20:20 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-04-19 22:07:06 +0200
commitfcb5979b4cfee7317178558117e00c8f9ca700f2 (patch)
tree43afb9af61a8ae62ad47315c8b94f81cc2255165 /app-text
parentlicenses: Remove unused ACML license (diff)
downloadgentoo-fcb5979b4cfee7317178558117e00c8f9ca700f2.tar.gz
gentoo-fcb5979b4cfee7317178558117e00c8f9ca700f2.tar.bz2
gentoo-fcb5979b4cfee7317178558117e00c8f9ca700f2.zip
app-text/pstotext: EAPI bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pstotext/pstotext-1.9-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/pstotext/pstotext-1.9-r4.ebuild b/app-text/pstotext/pstotext-1.9-r4.ebuild
new file mode 100644
index 000000000000..5aca5d7b5605
--- /dev/null
+++ b/app-text/pstotext/pstotext-1.9-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extract ASCII text from a PostScript or PDF file"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/doc/pstotext.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
+
+LICENSE="PSTT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/ncompress"
+RDEPEND="app-text/ghostscript-gpl"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-quote-chars-fix.patch
+ "${FILESDIR}"/${PV}-flags.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install () {
+ dobin pstotext
+ doman pstotext.1
+}