summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-18 14:45:41 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-18 15:39:59 +1000
commitc03602c25c7a357d4e391a20f72a30c1a880bb9e (patch)
tree2a88c61b95785abb82b5e15e1f1b681da7762b96 /dev-lang
parentdev-libs/ell: fix C23 compat (diff)
downloadgentoo-c03602c25c7a357d4e391a20f72a30c1a880bb9e.tar.gz
gentoo-c03602c25c7a357d4e391a20f72a30c1a880bb9e.tar.bz2
gentoo-c03602c25c7a357d4e391a20f72a30c1a880bb9e.zip
dev-lang/rust: libexec-${PV} symlink requires USE=rust-analyzer
Until 1.72.0 `cargo-credential-1password` was installed in `/usr/lib/rust/${PV}/libexec`, and we were able to unconditionally symlink that for eselect-rust to use. This is no longer the case and most of the time users end up with a broken symlink for each rust slot in /usr/lib/rust. Gate the symlink creation with the appropriate USE and conditionally add `/usr/lib/rust/libexec` to the eselect-rust provider config. Closes: https://bugs.gentoo.org/915403 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.74.1-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.75.0-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.77.1-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.79.0-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.80.1-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.81.0-r100.ebuild5
-rw-r--r--dev-lang/rust/rust-1.82.0-r100.ebuild4
7 files changed, 14 insertions, 20 deletions
diff --git a/dev-lang/rust/rust-1.74.1-r100.ebuild b/dev-lang/rust/rust-1.74.1-r100.ebuild
index 765b9f338a76..158a695500fa 100644
--- a/dev-lang/rust/rust-1.74.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.74.1-r100.ebuild
@@ -599,7 +599,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -623,7 +623,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -641,9 +640,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.75.0-r100.ebuild b/dev-lang/rust/rust-1.75.0-r100.ebuild
index 68b0dce91e37..cb184ff3fe86 100644
--- a/dev-lang/rust/rust-1.75.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.75.0-r100.ebuild
@@ -601,7 +601,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -625,7 +625,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -643,9 +642,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.77.1-r100.ebuild b/dev-lang/rust/rust-1.77.1-r100.ebuild
index d7e0c89e6a30..7d5dad178050 100644
--- a/dev-lang/rust/rust-1.77.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.77.1-r100.ebuild
@@ -600,7 +600,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -624,7 +624,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -642,9 +641,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.79.0-r100.ebuild b/dev-lang/rust/rust-1.79.0-r100.ebuild
index cb2c84a9e306..0453475c9add 100644
--- a/dev-lang/rust/rust-1.79.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.79.0-r100.ebuild
@@ -602,7 +602,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -626,7 +626,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -644,9 +643,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.80.1-r100.ebuild b/dev-lang/rust/rust-1.80.1-r100.ebuild
index 717fccf2b8e8..6ca29dc16db2 100644
--- a/dev-lang/rust/rust-1.80.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.80.1-r100.ebuild
@@ -600,7 +600,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -623,7 +623,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -641,9 +640,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.81.0-r100.ebuild b/dev-lang/rust/rust-1.81.0-r100.ebuild
index 8af903281b73..fd51c0508930 100644
--- a/dev-lang/rust/rust-1.81.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.81.0-r100.ebuild
@@ -604,7 +604,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -627,7 +627,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -645,9 +644,9 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi
-
insinto /etc/env.d/rust
doins "${T}/provider-${P}"
diff --git a/dev-lang/rust/rust-1.82.0-r100.ebuild b/dev-lang/rust/rust-1.82.0-r100.ebuild
index 396ab5c29179..a9d301b6a502 100644
--- a/dev-lang/rust/rust-1.82.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.82.0-r100.ebuild
@@ -614,7 +614,7 @@ src_install() {
# symlinks to switch components to active rust in eselect
dosym "${PV}/lib" "/usr/lib/${PN}/lib-${PV}"
- dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
+ use rust-analyzer && dosym "${PV}/libexec" "/usr/lib/${PN}/libexec-${PV}"
dosym "${PV}/share/man" "/usr/lib/${PN}/man-${PV}"
dosym "rust/${PV}/lib/rustlib" "/usr/lib/rustlib-${PV}"
dosym "../../lib/${PN}/${PV}/share/doc/rust" "/usr/share/doc/${P}"
@@ -637,7 +637,6 @@ src_install() {
/usr/bin/rust-lldb
/usr/lib/rustlib
/usr/lib/rust/lib
- /usr/lib/rust/libexec
/usr/lib/rust/man
/usr/share/doc/rust
_EOF_
@@ -655,6 +654,7 @@ src_install() {
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
fi
if use rust-analyzer; then
+ echo /usr/lib/rust/libexec >> "${T}/provider-${P}"
echo /usr/bin/rust-analyzer >> "${T}/provider-${P}"
fi