summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-08 21:20:06 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-08 21:20:57 +0200
commit17a87a43efc1bafd17efa0a03d5c2af7178ff904 (patch)
tree775b7addf129ba47803efb60ecd36064cbbd009a /mail-client
parentwww-client/firefox: check for sys-devel/llvm:$LLVM_SLOT in llvm_check_deps() (diff)
downloadgentoo-17a87a43efc1bafd17efa0a03d5c2af7178ff904.tar.gz
gentoo-17a87a43efc1bafd17efa0a03d5c2af7178ff904.tar.bz2
gentoo-17a87a43efc1bafd17efa0a03d5c2af7178ff904.zip
mail-client/thunderbird: check for sys-devel/llvm:$LLVM_SLOT in llvm_check_deps()
When we override llvm_check_deps(), we have to check for sys-devel/llvm:$LLVM_SLOT on our own. Bug: https://bugs.gentoo.org/788763 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-78.10.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/mail-client/thunderbird/thunderbird-78.10.1.ebuild b/mail-client/thunderbird/thunderbird-78.10.1.ebuild
index b2bba3955d0a..44fab69764a2 100644
--- a/mail-client/thunderbird/thunderbird-78.10.1.ebuild
+++ b/mail-client/thunderbird/thunderbird-78.10.1.ebuild
@@ -192,6 +192,11 @@ DEPEND="${CDEPEND}
S="${WORKDIR}/${PN}-${PV%_*}"
llvm_check_deps() {
+ if ! has_version -b "sys-devel/llvm:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/llvm:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1