summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-27 20:55:43 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-27 20:55:43 +0000
commit9df03a9daac7906fae590a3d6d09cf25151794b2 (patch)
treecd51f00bc38e8c91206566c6fc7008fdf3cee0bb /dev-python
parentUncommented a line that shouldn't have been commented out :) (diff)
downloadhistorical-9df03a9daac7906fae590a3d6d09cf25151794b2.tar.gz
historical-9df03a9daac7906fae590a3d6d09cf25151794b2.tar.bz2
historical-9df03a9daac7906fae590a3d6d09cf25151794b2.zip
New version of sip.. Now 3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/files/digest-sip-3.01
-rw-r--r--dev-python/sip/sip-3.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sip/files/digest-sip-3.0 b/dev-python/sip/files/digest-sip-3.0
new file mode 100644
index 000000000000..4a42b5cad395
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-3.0
@@ -0,0 +1 @@
+MD5 d55ffd4601a6c75b06c072b58e430bf9 sip-3.0.tar.gz 331776
diff --git a/dev-python/sip/sip-3.0.ebuild b/dev-python/sip/sip-3.0.ebuild
new file mode 100644
index 000000000000..434a1469f284
--- /dev/null
+++ b/dev-python/sip/sip-3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.0.ebuild,v 1.1 2001/11/27 20:55:43 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
+HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+
+DEPEND="virtual/glibc
+ virtual/python"
+
+src_compile(){
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING NEWS README THANKS TODO
+}