summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-08-03 09:10:31 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-08-03 09:10:31 +0000
commit542fe40055443cd1fd2a1325a05947c8403a16fe (patch)
treeee3d5dfe3948879cc18d710f93c0eca918d020e9 /net-mail
parent4 new ebuilds by Craig Joly, read the wiki note before working on them (diff)
downloadhistorical-542fe40055443cd1fd2a1325a05947c8403a16fe.tar.gz
historical-542fe40055443cd1fd2a1325a05947c8403a16fe.tar.bz2
historical-542fe40055443cd1fd2a1325a05947c8403a16fe.zip
A bunch of bbtools ebuilds from Craig Joly <joly@ee.ualberta.ca> and myself Joe Bormolini <lordjoe@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/bbmail/bbmail-0.6.11.ebuild35
-rw-r--r--net-mail/bbmail/files/bbmail-qmail.patch35
-rw-r--r--net-mail/bbmail/files/digest-bbmail-0.6.111
3 files changed, 71 insertions, 0 deletions
diff --git a/net-mail/bbmail/bbmail-0.6.11.ebuild b/net-mail/bbmail/bbmail-0.6.11.ebuild
new file mode 100644
index 000000000000..134913370f08
--- /dev/null
+++ b/net-mail/bbmail/bbmail-0.6.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox mail notification, patched for maildir"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}.tar.gz"
+HOMEPAGE="http://bbtools.thelinuxcommunity.org/available.phtml"
+
+DEPEND=">=x11-wm/blackbox-0.61"
+
+src_unpack () {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ # This is a patch for bbmail to support qmail style maildirs
+ try patch -p1 < ${FILESDIR}/bbmail-qmail.patch
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO data/README.bbmail
+ cd /usr/X11R6/bin/wm
+ cp blackbox blackbox.bak
+ sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbmail \&\n&": blackbox.bak > blackbox
+}
diff --git a/net-mail/bbmail/files/bbmail-qmail.patch b/net-mail/bbmail/files/bbmail-qmail.patch
new file mode 100644
index 000000000000..8e23afd63991
--- /dev/null
+++ b/net-mail/bbmail/files/bbmail-qmail.patch
@@ -0,0 +1,35 @@
+--- bbmail-0.6.10.orig/bbmail.cc
++++ bbmail-0.6.10/bbmail.cc
+@@ -55,7 +55,7 @@
+ }
+
+ bool Checkmail::CheckMHBox(int spoolno,bool force) {
+- struct stat file_status;
++ struct stat file_status, maildir_status;
+ FILE *fp;
+ int num[2]={-1,-1};
+ int number_of_values;
+@@ -67,6 +67,23 @@
+ bbtool->getResource()->spoolfile[spoolno].filename);
+ return(false);
+ }
++
++ // check maildir new/ and cur/ directories
++ char *maildir = new
++ char[strlen (bbtool->getResource()->spoolfile[spoolno].filename) + 5];
++ sprintf (maildir, "%s/new", bbtool->getResource()->spoolfile[spoolno].filename);
++ if (stat (maildir, &maildir_status) == 0 &&
++ maildir_status.st_mtime > file_status.st_mtime) {
++ file_status.st_mtime = maildir_status.st_mtime;
++ }
++
++ sprintf (maildir, "%s/cur", bbtool->getResource()->spoolfile[spoolno].filename);
++ if (stat (maildir, &maildir_status) == 0 &&
++ maildir_status.st_mtime > file_status.st_mtime) {
++ file_status.st_mtime = maildir_status.st_mtime;
++ }
++
++ delete [] maildir;
+ }
+
+ if ((file_status.st_mtime != spoolfile[spoolno].last_mtime)&&
diff --git a/net-mail/bbmail/files/digest-bbmail-0.6.11 b/net-mail/bbmail/files/digest-bbmail-0.6.11
new file mode 100644
index 000000000000..98e7288a0d76
--- /dev/null
+++ b/net-mail/bbmail/files/digest-bbmail-0.6.11
@@ -0,0 +1 @@
+MD5 26e442a09ceab67a39b73ad80ceafff9 bbmail-0.6.11.tar.gz