summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/netcdf/netcdf-3.5.0-r1.ebuild')
-rw-r--r--app-sci/netcdf/netcdf-3.5.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-sci/netcdf/netcdf-3.5.0-r1.ebuild b/app-sci/netcdf/netcdf-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..9941851b9845
--- /dev/null
+++ b/app-sci/netcdf/netcdf-3.5.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod M. Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r1.ebuild,v 1.1 2002/05/08 02:04:28 george Exp $
+
+S=${WORKDIR}/${P}/src
+DESCRIPTION="Interface for array oriented data access"
+
+#Note orig source archive does not have version # in filename
+#SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${PN}.tar.Z"
+#but most of the mirrors do.
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
+
+HOMEPAGE="http://www.unidaa.ucar.edu/packages/netcdf/"
+
+DEPEND="virtual/glibc"
+
+PROVIDE="app-misc/netcdf"
+
+src_compile() {
+ export CPPFLAGS=-Df2cFortran
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die
+
+ emake || die
+
+ make test || die
+}
+
+src_install() {
+ dodir /usr/{lib,share}
+
+ make prefix=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ dodoc COMPATIBILITY COPYRIGHT INSTALL.html MANIFEST
+ dodoc README RELEASE_NOTES VERSION
+}