summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/netcdf')
-rw-r--r--app-sci/netcdf/ChangeLog13
-rw-r--r--app-sci/netcdf/files/digest-netcdf-3.5.0-r11
-rw-r--r--app-sci/netcdf/netcdf-3.5.0-r1.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/app-sci/netcdf/ChangeLog b/app-sci/netcdf/ChangeLog
new file mode 100644
index 000000000000..afa0cae46066
--- /dev/null
+++ b/app-sci/netcdf/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-sci/netcdf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/ChangeLog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*netcdf-3.5.0-r1 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/netcdf/files/digest-netcdf-3.5.0-r1 b/app-sci/netcdf/files/digest-netcdf-3.5.0-r1
new file mode 100644
index 000000000000..25d6e8d0de3d
--- /dev/null
+++ b/app-sci/netcdf/files/digest-netcdf-3.5.0-r1
@@ -0,0 +1 @@
+MD5 28640a40a44f982f90f5eeb15e917a1f netcdf-3.5.0.tar.Z 1319419
diff --git a/app-sci/netcdf/netcdf-3.5.0-r1.ebuild b/app-sci/netcdf/netcdf-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..9941851b9845
--- /dev/null
+++ b/app-sci/netcdf/netcdf-3.5.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod M. Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r1.ebuild,v 1.1 2002/05/08 02:04:28 george Exp $
+
+S=${WORKDIR}/${P}/src
+DESCRIPTION="Interface for array oriented data access"
+
+#Note orig source archive does not have version # in filename
+#SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${PN}.tar.Z"
+#but most of the mirrors do.
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
+
+HOMEPAGE="http://www.unidaa.ucar.edu/packages/netcdf/"
+
+DEPEND="virtual/glibc"
+
+PROVIDE="app-misc/netcdf"
+
+src_compile() {
+ export CPPFLAGS=-Df2cFortran
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die
+
+ emake || die
+
+ make test || die
+}
+
+src_install() {
+ dodir /usr/{lib,share}
+
+ make prefix=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ dodoc COMPATIBILITY COPYRIGHT INSTALL.html MANIFEST
+ dodoc README RELEASE_NOTES VERSION
+}