aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-03-11 12:31:10 -0800
committerSteve Arnold <nerdboy@gentoo.org>2017-03-11 12:31:10 -0800
commitfd6236b0e2e4073df29b535570caa5fa4e6ca97e (patch)
tree492a6e3a5eb1eeac716b5c05f870ccbd2238bae3 /dev-libs
parentredis-ipc-0.0.1: new ebuild, still testing autotools config (diff)
downloadarm-fd6236b0e2e4073df29b535570caa5fa4e6ca97e.tar.gz
arm-fd6236b0e2e4073df29b535570caa5fa4e6ca97e.tar.bz2
arm-fd6236b0e2e4073df29b535570caa5fa4e6ca97e.zip
redis-ipc: fix license and update patch for expected test results
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch12
-rw-r--r--dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild3
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch b/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch
index b9a0410..ecc9a28 100644
--- a/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch
+++ b/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch
@@ -63,7 +63,7 @@ index c603c21..c3820d5 100644
// should submit a result. The original command is passed in as a parameter
// to provide the command ID and path to results queue. The command ID
diff --git a/test/Makefile.am b/test/Makefile.am
-index 5493edc..eb05acf 100644
+index 5493edc..a73edc0 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
@@ -72,7 +72,15 @@ index 5493edc..eb05acf 100644
LIBREDISIPC = $(top_srcdir)/src/.libs/libredis_ipc.la
-@@ -14,22 +14,22 @@ check_PROGRAMS = $(BUILT_TESTS)
+@@ -8,28 +8,30 @@ BUILT_TESTS = command_result_test \
+ settings_status_test \
+ pub_sub_test
+
++XFAIL_TESTS = command_result_test
++
+ #TESTS = $(BUILT_TESTS) tests/runtests.sh
+ TESTS = $(check_PROGRAMS)
+ check_PROGRAMS = $(BUILT_TESTS)
include_HEADERS = $(top_srcdir)/inc/json.hh
command_result_test_SOURCES = command_result_test.c
diff --git a/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild b/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild
index eb37abd..7c6b97c 100644
--- a/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild
+++ b/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild
@@ -19,7 +19,7 @@ fi
DESCRIPTION="A wrapper library for using redis server and JSON as IPC mechanism"
HOMEPAGE="https://github.com/VCTLabs/redis-ipc"
-LICENSE="Apache-2.0"
+LICENSE="GPL-2"
SLOT="0"
DEPEND="virtual/pkgconfig
@@ -41,3 +41,4 @@ src_configure() {
$(use_enable static) \
"${myconf[@]}"
}
+