aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-24 14:22:48 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-24 14:22:48 +0200
commitf405028bfbbd32859d3359f3654a3752145b6345 (patch)
treeae989af4523605cbe430b1b2bf683ccb84aec8c6 /gui-apps
parentx11-libs/gtk-fortran: add USE="static-libs" conditional patch (diff)
downloadguru-f405028bfbbd32859d3359f3654a3752145b6345.tar.gz
guru-f405028bfbbd32859d3359f3654a3752145b6345.tar.bz2
guru-f405028bfbbd32859d3359f3654a3752145b6345.zip
gui-apps/paperde: add missing extra-cmake-modules dep; mv MY_PV
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/paperde/paperde-0.1.0_alpha.ebuild10
-rw-r--r--gui-apps/paperde/paperde-0.1.1.ebuild10
-rw-r--r--gui-apps/paperde/paperde-9999.ebuild10
3 files changed, 18 insertions, 12 deletions
diff --git a/gui-apps/paperde/paperde-0.1.0_alpha.ebuild b/gui-apps/paperde/paperde-0.1.0_alpha.ebuild
index 0ea5e6bbc..7a7482b76 100644
--- a/gui-apps/paperde/paperde-0.1.0_alpha.ebuild
+++ b/gui-apps/paperde/paperde-0.1.0_alpha.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-# _alpha -> -alpha
-MY_PV="${PV/_/-}"
-
inherit cmake xdg
DESCRIPTION="Simple, sleek QT based DE for wayland using wayfire"
HOMEPAGE="https://gitlab.com/cubocore/paper/paperde"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/paper/${PN}.git"
else
+ # _alpha -> -alpha
+ MY_PV="${PV/_/-}"
SRC_URI="https://gitlab.com/cubocore/paper/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${MY_PV}"
@@ -23,6 +22,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
DEPEND="
dev-libs/libdbusmenu-qt
dev-libs/wayland
diff --git a/gui-apps/paperde/paperde-0.1.1.ebuild b/gui-apps/paperde/paperde-0.1.1.ebuild
index 0ea5e6bbc..7a7482b76 100644
--- a/gui-apps/paperde/paperde-0.1.1.ebuild
+++ b/gui-apps/paperde/paperde-0.1.1.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-# _alpha -> -alpha
-MY_PV="${PV/_/-}"
-
inherit cmake xdg
DESCRIPTION="Simple, sleek QT based DE for wayland using wayfire"
HOMEPAGE="https://gitlab.com/cubocore/paper/paperde"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/paper/${PN}.git"
else
+ # _alpha -> -alpha
+ MY_PV="${PV/_/-}"
SRC_URI="https://gitlab.com/cubocore/paper/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${MY_PV}"
@@ -23,6 +22,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
DEPEND="
dev-libs/libdbusmenu-qt
dev-libs/wayland
diff --git a/gui-apps/paperde/paperde-9999.ebuild b/gui-apps/paperde/paperde-9999.ebuild
index 0ea5e6bbc..7a7482b76 100644
--- a/gui-apps/paperde/paperde-9999.ebuild
+++ b/gui-apps/paperde/paperde-9999.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-# _alpha -> -alpha
-MY_PV="${PV/_/-}"
-
inherit cmake xdg
DESCRIPTION="Simple, sleek QT based DE for wayland using wayfire"
HOMEPAGE="https://gitlab.com/cubocore/paper/paperde"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/paper/${PN}.git"
else
+ # _alpha -> -alpha
+ MY_PV="${PV/_/-}"
SRC_URI="https://gitlab.com/cubocore/paper/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${MY_PV}"
@@ -23,6 +22,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
DEPEND="
dev-libs/libdbusmenu-qt
dev-libs/wayland