summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/pgrouting/files/no-contrib-when-use-extension.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/pgrouting/files/no-contrib-when-use-extension.patch')
-rw-r--r--dev-db/pgrouting/files/no-contrib-when-use-extension.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-db/pgrouting/files/no-contrib-when-use-extension.patch b/dev-db/pgrouting/files/no-contrib-when-use-extension.patch
new file mode 100644
index 000000000000..e26af3ef0da3
--- /dev/null
+++ b/dev-db/pgrouting/files/no-contrib-when-use-extension.patch
@@ -0,0 +1,76 @@
+diff -Naur pgrouting-2.0.0.orig/CMakeLists.txt pgrouting-2.0.0/CMakeLists.txt
+--- pgrouting-2.0.0.orig/CMakeLists.txt 2013-09-24 16:38:31.000000000 -0400
++++ pgrouting-2.0.0/CMakeLists.txt 2014-11-07 06:48:11.555026180 -0500
+@@ -170,16 +170,13 @@
+ OUTPUT_VARIABLE SHARE_DIR)
+
+ if(SHARE_DIR)
+- # Always install in "contrib" directory of PostgreSQL
+- set(CONTRIB_DIR "${SHARE_DIR}/contrib/pgrouting-${PGROUTING_VERSION_MAJOR}.${PGROUTING_VERSION_MINOR}")
+- message(STATUS "Contrib directory for SQL files is set to ${CONTRIB_DIR}")
+-
+ # Install as extension if supported by the version of PostgreSQL
+ if(USE_PG_EXTENSION)
+ set(SHARE_DIR "${SHARE_DIR}/extension")
+ message(STATUS "Extension directory for SQL files is set to ${SHARE_DIR}")
+- #else(USE_PG_EXTENSION)
+- # set(SHARE_DIR "/usr/share/pgrouting")
++ else(USE_PG_EXTENSION)
++ set(CONTRIB_DIR "${SHARE_DIR}/contrib/pgrouting-${PGROUTING_VERSION_MAJOR}.${PGROUTING_VERSION_MINOR}")
++ message(STATUS "Contrib directory for SQL files is set to ${CONTRIB_DIR}")
+ endif(USE_PG_EXTENSION)
+ else(SHARE_DIR)
+ message(FATAL_ERROR "pg_config --sharedir failed to return a value. Please check your PostgreSQL installation!")
+@@ -347,22 +344,24 @@
+
+ install(FILES ${LIBS_TO_INSTALL} DESTINATION ${LIB_DIR})
+
+-install(FILES
++if(USE_PG_EXTENSION)
++ install(FILES
+ "${CMAKE_BINARY_DIR}/lib/pgrouting--${PGROUTING_VERSION_STRING}.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.control"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting_legacy.sql"
+ DESTINATION "${SHARE_DIR}")
+-
+-# The following probably could be done better
+-# The idea is to also have a "pgrouting-x.x" directory in PostgreSQL contrib
+-configure_file("${CMAKE_BINARY_DIR}/lib/pgrouting--${PGROUTING_VERSION_STRING}.sql"
++else(USE_PG_EXTENSION)
++ # The following probably could be done better
++ # The idea is to also have a "pgrouting-x.x" directory in PostgreSQL contrib
++ configure_file("${CMAKE_BINARY_DIR}/lib/pgrouting--${PGROUTING_VERSION_STRING}.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.sql" COPYONLY)
+
+-install(FILES
++ install(FILES
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.control"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting_legacy.sql"
+ DESTINATION "${CONTRIB_DIR}")
++endif(USE_PG_EXTENSION)
+
+ # TODO: The following probably should be done better
+ if(WITH_DD)
+@@ -372,12 +371,14 @@
+ configure_file("${PGROUTING_SOURCE_DIR}/src/driving_distance/sql/routing_dd_legacy.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql" COPYONLY)
+
+- install(FILES
+- "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
+- DESTINATION "${SHARE_DIR}")
+-
+- install(FILES
+- "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
+- DESTINATION "${CONTRIB_DIR}")
++ if(USE_PG_EXTENSION)
++ install(FILES
++ "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
++ DESTINATION "${SHARE_DIR}")
++ else(USE_PG_EXTENSION)
++ install(FILES
++ "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
++ DESTINATION "${CONTRIB_DIR}")
++ endif(USE_PG_EXTENSION)
+ endif(WITH_DD)
+