summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-11 20:58:45 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-11 20:58:45 -0400
commit3f74e0196b4719fb8f10118c80de15fa823797a6 (patch)
treecc13289da2d9526b93e2940194da306d8d78ac32 /dev-lang/python/python-3.5.1-r2.ebuild
parentdev-util/artifactory-bin: initial packaging for 4.7.6 (diff)
downloadgentoo-3f74e0196b4719fb8f10118c80de15fa823797a6.tar.gz
gentoo-3f74e0196b4719fb8f10118c80de15fa823797a6.tar.bz2
gentoo-3f74e0196b4719fb8f10118c80de15fa823797a6.zip
dev-lang/python: fix cross-compiles for 3.5.1
Bug: https://bugs.gentoo.org/581304 Package-Manager: portage-2.2.28_p106
Diffstat (limited to 'dev-lang/python/python-3.5.1-r2.ebuild')
-rw-r--r--dev-lang/python/python-3.5.1-r2.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.5.1-r2.ebuild b/dev-lang/python/python-3.5.1-r2.ebuild
index 0f2fa796d3ac..480c6ad515ae 100644
--- a/dev-lang/python/python-3.5.1-r2.ebuild
+++ b/dev-lang/python/python-3.5.1-r2.ebuild
@@ -71,7 +71,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
- epatch "${FILESDIR}/3.5-secondary-targets.patch"
+ epatch "${FILESDIR}/3.5.1-cross-compile.patch"
epatch_user
@@ -87,8 +87,6 @@ src_prepare() {
Modules/Setup.dist \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- #sed -i -e 's/\$(GRAMMAR_H): \$(GRAMMAR_INPUT) \$(PGEN)/$(GRAMMAR_H): \$(GRAMMAR_INPUT)/' Makefile.pre.in || die
-
eautoreconf
}
@@ -174,9 +172,6 @@ src_configure() {
}
src_compile() {
- # Avoid regenerating these for cross-compiles
- touch Include/graminit.h Python/graminit.c Python/importlib.h Python/importlib_external.h || die
-
cd "${BUILD_DIR}" || die
emake CPPFLAGS= CFLAGS= LDFLAGS=