summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.5.1-r2.ebuild')
-rw-r--r--dev-lang/python/python-3.5.1-r2.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.5.1-r2.ebuild b/dev-lang/python/python-3.5.1-r2.ebuild
index 0f2fa796d3ac..480c6ad515ae 100644
--- a/dev-lang/python/python-3.5.1-r2.ebuild
+++ b/dev-lang/python/python-3.5.1-r2.ebuild
@@ -71,7 +71,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
- epatch "${FILESDIR}/3.5-secondary-targets.patch"
+ epatch "${FILESDIR}/3.5.1-cross-compile.patch"
epatch_user
@@ -87,8 +87,6 @@ src_prepare() {
Modules/Setup.dist \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- #sed -i -e 's/\$(GRAMMAR_H): \$(GRAMMAR_INPUT) \$(PGEN)/$(GRAMMAR_H): \$(GRAMMAR_INPUT)/' Makefile.pre.in || die
-
eautoreconf
}
@@ -174,9 +172,6 @@ src_configure() {
}
src_compile() {
- # Avoid regenerating these for cross-compiles
- touch Include/graminit.h Python/graminit.c Python/importlib.h Python/importlib_external.h || die
-
cd "${BUILD_DIR}" || die
emake CPPFLAGS= CFLAGS= LDFLAGS=