summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 16:22:01 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 18:12:02 +0300
commit0c0de4f445c06c998c4ffbb565425fc702d3a3ec (patch)
treebdaae8b94736bee90008848c271e20ee47e63a0f /dev-python/citeproc-py
parentdev-python/rnc2rng: Add py3.7 (diff)
downloadgentoo-0c0de4f445c06c998c4ffbb565425fc702d3a3ec.tar.gz
gentoo-0c0de4f445c06c998c4ffbb565425fc702d3a3ec.tar.bz2
gentoo-0c0de4f445c06c998c4ffbb565425fc702d3a3ec.zip
dev-python/citeproc-py: Add py3.7 and move to eapi7
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/citeproc-py')
-rw-r--r--dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild (renamed from dev-python/citeproc-py/citeproc-py-0.4.0.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/citeproc-py/citeproc-py-0.4.0.ebuild b/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
index 2e0420e00d44..b81b9c57d500 100644
--- a/dev-python/citeproc-py/citeproc-py-0.4.0.ebuild
+++ b/dev-python/citeproc-py/citeproc-py-0.4.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="Yet another Python CSL Processor"
@@ -17,6 +17,8 @@ IUSE=""
PATCHES=( "${FILESDIR}/b1a5f925527093b0b5c11507f379a908e3354820.patch" )
-DEPEND="
+RDEPEND="
dev-python/rnc2rng[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"