summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 20:37:22 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 20:37:22 +0200
commit7263ce6a990dcc3b73e403401cc84d092402d7e5 (patch)
tree8dfb8ae0389e455479d8f7f035288a785a5dad80 /dev-python/nbdime
parentdev-python/nbdime: Version bump to 2.0.0 (diff)
downloadgentoo-7263ce6a990dcc3b73e403401cc84d092402d7e5.tar.gz
gentoo-7263ce6a990dcc3b73e403401cc84d092402d7e5.tar.bz2
gentoo-7263ce6a990dcc3b73e403401cc84d092402d7e5.zip
dev-python/nbdime: Remove old 0.2.0
Closes: https://bugs.gentoo.org/719106 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest1
-rw-r--r--dev-python/nbdime/nbdime-0.2.0.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index ada1366ba877..5518da014d1b 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1,2 +1 @@
-DIST nbdime-0.2.0.tar.gz 4139079 BLAKE2B 1e6994009c8ac291272a297fe583f79123906c9e05ca2afd345c6e230e3c476259c4919e2161a049e46fa28f4490122c53d0a2bc94661683652d226a78fb39be SHA512 c156b706e1d6cc7885f987d746e91d7f0c2fa48885339fd79e778643382ab45e2e52565f45cc73b9a305c6f5177339e875f53ae46d73578443880a4c7522976d
DIST nbdime-2.0.0.tar.gz 7768807 BLAKE2B a92ed166ae863185d06e4b3e667df4323b4cd9af9211999109186c1b559522f39ab235b710c7993515aa3c44a55ac3c4b90c424cdc28d04cc013a58add7d61cd SHA512 e68e69e37f6ece701ba8d6e59d8ee321ddaca78d9338e0c52f92b6942bfd3fbf0ec2407e9ae98cb820eb4c26509644a1770f249b815c53265dfdbffbe2b55142
diff --git a/dev-python/nbdime/nbdime-0.2.0.ebuild b/dev-python/nbdime/nbdime-0.2.0.ebuild
deleted file mode 100644
index 63b92348ff58..000000000000
--- a/dev-python/nbdime/nbdime-0.2.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test webtools"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- webtools? ( net-libs/nodejs[npm] )
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
- "
-# The package recommonmark is required to build the docs, not in portage yet.
-# Furthermore, backports.shutil_which is required for python2_7.
-
-python_configure_all() {
- if ! use webtools; then
- mydistutilsargs=( --skip-npm )
- fi
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- # user.email and user.name are not configured in the sandbox.
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
-
- distutils_install_for_testing
-
- py.test -l || die
-}