summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/posix_ipc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/posix_ipc')
-rw-r--r--dev-python/posix_ipc/Manifest1
-rw-r--r--dev-python/posix_ipc/metadata.xml15
-rw-r--r--dev-python/posix_ipc/posix_ipc-0.9.8.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/posix_ipc/Manifest b/dev-python/posix_ipc/Manifest
new file mode 100644
index 000000000000..fd45b4eaa61d
--- /dev/null
+++ b/dev-python/posix_ipc/Manifest
@@ -0,0 +1 @@
+DIST posix_ipc-0.9.8.tar.gz 66589 SHA256 271446eb133efb7410eb51265807aa54e0acb8eb7c2abcf027e51b4cb36d36dd SHA512 d0618c302e6d0f9113b9515627095d6baf383dcf4ac603b3a4596ee814873a0baa473e8505918859bda37cb539f98e76fd601e29f6772dbc14f74d6059fd4200 WHIRLPOOL 1c7ff555fdd9050b6c075873141030e0672c6f159ba68ea2f1f9d80cb18539ed7cd9fbfba772ee2be7754fad85943befc11805f8b4ba7eb2bf0cbcf7db5eafe3
diff --git a/dev-python/posix_ipc/metadata.xml b/dev-python/posix_ipc/metadata.xml
new file mode 100644
index 000000000000..12f81c32d1bf
--- /dev/null
+++ b/dev-python/posix_ipc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ POSIX IPC primitives (semaphores, shared memory and message queues) for Python
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">posix_ipc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/posix_ipc/posix_ipc-0.9.8.ebuild b/dev-python/posix_ipc/posix_ipc-0.9.8.ebuild
new file mode 100644
index 000000000000..f154f9444683
--- /dev/null
+++ b/dev-python/posix_ipc/posix_ipc-0.9.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX IPC primitives (semaphores, shared memory and message queues) for Python"
+HOMEPAGE="http://semanchuk.com/philip/posix_ipc/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""