summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-07-03 14:39:05 -0400
committerKenton Groombridge <concord@gentoo.org>2022-07-03 15:17:46 -0400
commitb19b7b7bfa8854ff98ffe5bee099e256cae9fa23 (patch)
tree4eae66be5b920f50d13e7cfc53467749b85815b1 /net-voip
parentnet-voip/mumble: append -fsigned-char to CXXFLAGS (diff)
downloadgentoo-b19b7b7bfa8854ff98ffe5bee099e256cae9fa23.tar.gz
gentoo-b19b7b7bfa8854ff98ffe5bee099e256cae9fa23.tar.bz2
gentoo-b19b7b7bfa8854ff98ffe5bee099e256cae9fa23.zip
net-voip/murmur: append -fsigned-char to CXXFLAGS
This fixes tests (and possibly runtime issues) on arches with unsigned chars. Bug: https://bugs.gentoo.org/832978 Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/murmur/murmur-1.4.230-r2.ebuild7
-rw-r--r--net-voip/murmur/murmur-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-voip/murmur/murmur-1.4.230-r2.ebuild b/net-voip/murmur/murmur-1.4.230-r2.ebuild
index d0e26545bd3d..cb402564c70b 100644
--- a/net-voip/murmur/murmur-1.4.230-r2.ebuild
+++ b/net-voip/murmur/murmur-1.4.230-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake systemd readme.gentoo-r1 tmpfiles
+inherit cmake flag-o-matic systemd readme.gentoo-r1 tmpfiles
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -125,6 +125,11 @@ src_configure() {
if [[ "${PV}" != 9999 ]] ; then
mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
fi
+
+ # https://bugs.gentoo.org/832978
+ # fix tests (and possibly runtime issues) on arches with unsigned chars
+ append-cxxflags -fsigned-char
+
cmake_src_configure
}
diff --git a/net-voip/murmur/murmur-9999.ebuild b/net-voip/murmur/murmur-9999.ebuild
index d5c37496cf5d..00fd25ef4af5 100644
--- a/net-voip/murmur/murmur-9999.ebuild
+++ b/net-voip/murmur/murmur-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake systemd readme.gentoo-r1 tmpfiles
+inherit cmake flag-o-matic systemd readme.gentoo-r1 tmpfiles
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -119,6 +119,11 @@ src_configure() {
if [[ "${PV}" != 9999 ]] ; then
mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
fi
+
+ # https://bugs.gentoo.org/832978
+ # fix tests (and possibly runtime issues) on arches with unsigned chars
+ append-cxxflags -fsigned-char
+
cmake_src_configure
}