summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libjcat/libjcat-0.1.8.ebuild2
-rw-r--r--dev-python/pytest-subtesthack/Manifest1
-rw-r--r--dev-python/pytest-subtesthack/metadata.xml1
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild (renamed from dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild)17
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild2
-rw-r--r--dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch25
-rw-r--r--dev-python/vdirsyncer/metadata.xml1
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.18.0-r1.ebuild63
-rw-r--r--eclass/autotools.eclass21
-rw-r--r--sys-apps/util-linux/files/util-linux-2.37-avoid_autoreconf.patch136
-rw-r--r--sys-apps/util-linux/files/util-linux-2.37-lcrypt_link_fix.patch50
-rw-r--r--sys-apps/util-linux/files/util-linux-2.37-lcrypt_use_LIBS.patch91
-rw-r--r--sys-apps/util-linux/util-linux-2.37.ebuild4
13 files changed, 394 insertions, 20 deletions
diff --git a/dev-libs/libjcat/libjcat-0.1.8.ebuild b/dev-libs/libjcat/libjcat-0.1.8.ebuild
index 20c253ee26f3..11fd5361f10f 100644
--- a/dev-libs/libjcat/libjcat-0.1.8.ebuild
+++ b/dev-libs/libjcat/libjcat-0.1.8.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-IUSE="gpg gtk-doc +introspection +man pkcs7 test vala"
+IUSE="+gpg gtk-doc +introspection +man +pkcs7 test vala"
RDEPEND="dev-libs/glib:2
dev-libs/json-glib:=
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index 831610c75eb0..ec39bdad2850 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1,2 +1 @@
-DIST pytest-subtesthack-0.1.1.tar.gz 2410 BLAKE2B 3d41950ad46bb07da145db7f88eba7eb34a2bbb99273f47d2443cae5ab0e11737f1c2fe81bf473180178b2ad9e55b252c7717846f1b010cc58fb1bf61380d003 SHA512 0bf6425b535e65dc7f06f74493d10fbb6451e78a817174638661d7525f39f092f67db8da010228cbd54b400485e71e443118f91ebef660b9c00d2b354062a55f
DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
diff --git a/dev-python/pytest-subtesthack/metadata.xml b/dev-python/pytest-subtesthack/metadata.xml
index 83cea879f32e..3bd46636104a 100644
--- a/dev-python/pytest-subtesthack/metadata.xml
+++ b/dev-python/pytest-subtesthack/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pytest-subtesthack</remote-id>
<remote-id type="github">untitaker/pytest-subtesthack</remote-id>
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild
index 1c2580a1e3e2..605571f39759 100644
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,18 +15,11 @@ SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz ->
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
test? (
dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)"
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
index ecf80737e6ff..9738c6bb61a2 100644
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
diff --git a/dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch b/dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch
new file mode 100644
index 000000000000..d7e1d537ce49
--- /dev/null
+++ b/dev-python/vdirsyncer/files/vdirsyncer-0.18.0-no-cov.patch
@@ -0,0 +1,25 @@
+Avoid pytest-cov involvement:
+
+https://dev.gentoo.org/~mgorny/python-guide/pytest.html#avoiding-dependencies-on-other-pytest-plugins
+
+Signed-Off-By: John Helmert III <ajak@gentoo.org>
+
+diff --git a/setup.cfg b/setup.cfg
+index 2428e44..117f237 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,14 +1,6 @@
+ [wheel]
+ universal = 1
+
+-[tool:pytest]
+-addopts =
+- --tb=short
+- --cov-config .coveragerc
+- --cov=vdirsyncer
+- --cov-report=term-missing
+- --no-cov-on-fail
+-
+ [flake8]
+ application-import-names = tests,vdirsyncer
+ extend-ignore =
diff --git a/dev-python/vdirsyncer/metadata.xml b/dev-python/vdirsyncer/metadata.xml
index f42dda4bb8ac..2cf2c2526681 100644
--- a/dev-python/vdirsyncer/metadata.xml
+++ b/dev-python/vdirsyncer/metadata.xml
@@ -8,6 +8,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">pimutils/vdirsyncer</remote-id>
<remote-id type="pypi">vdirsyncer</remote-id>
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.18.0-r1.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..21d72fd5f54a
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.18.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/pimutils/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-threading-0.5[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.18.0-no-cov.patch"
+)
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+distutils_enable_tests pytest
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+
+ local deselect=(
+ # test CA is too weak for modern python
+ tests/system/utils/test_main.py::test_request_ssl
+ tests/system/utils/test_main.py::test_request_ssl_fingerprints
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ systemd_dounit contrib/vdirsyncer.{service,timer}
+}
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index b386654c8328..837f9e7a9aab 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -4,7 +4,7 @@
# @ECLASS: autotools.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: Regenerates auto* build scripts
# @DESCRIPTION:
# This eclass is for safely handling autotooled software packages that need to
@@ -31,7 +31,7 @@ case ${EAPI} in
# Needed for eqawarn
inherit eutils
;;
- 7) ;;
+ 7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI} not supported" ;;
esac
@@ -373,10 +373,21 @@ eautoconf() {
die "No configure.{ac,in} present!"
fi
+
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- eqawarn "This package has a configure.in file which has long been deprecated. Please"
- eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
- eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ case ${EAPI:-0} in
+ 0|1|2|3|4|5|6|7)
+ eqawarn "This package has a configure.in file which has long been deprecated. Please"
+ eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
+ eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
+ ;;
+ *)
+ # Move configure file to the new location only on newer EAPIs to ensure
+ # checks are done rather than retroactively breaking ebuilds.
+ eqawarn "Moving configure.in to configure.ac (bug #426262)"
+ mv configure.{in,ac} || die
+ ;;
+ esac
fi
# Install config.guess and config.sub which are required by many macros
diff --git a/sys-apps/util-linux/files/util-linux-2.37-avoid_autoreconf.patch b/sys-apps/util-linux/files/util-linux-2.37-avoid_autoreconf.patch
new file mode 100644
index 000000000000..44ea6e5c2bed
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.37-avoid_autoreconf.patch
@@ -0,0 +1,136 @@
+--- util-linux-2.37/config.h.in
++++ util-linux-2.37/config.h.in
+@@ -216,9 +216,6 @@
+ /* Define to 1 if you have the `cap-ng' library (-lcap-ng). */
+ #undef HAVE_LIBCAP_NG
+
+-/* Do we need -lcrypt? */
+-#undef HAVE_LIBCRYPT
+-
+ /* Define if libeconf is available */
+ #undef HAVE_LIBECONF
+
+--- util-linux-2.37/configure
++++ util-linux-2.37/configure
+@@ -4965,12 +4965,7 @@
+ program_transform_name=`$as_echo "$program_transform_name" | sed "$ac_script"`
+
+ if test x"${MISSING+set}" != xset; then
+- case $am_aux_dir in
+- *\ * | *\ *)
+- MISSING="\${SHELL} \"$am_aux_dir/missing\"" ;;
+- *)
+- MISSING="\${SHELL} $am_aux_dir/missing" ;;
+- esac
++ MISSING="\${SHELL} '$am_aux_dir/missing'"
+ fi
+ # Use eval to expand $SHELL
+ if eval "$MISSING --is-lightweight"; then
+@@ -25591,7 +25586,10 @@
+
+ else
+
++
++ old_LIBS="$LIBS"
+ LIBS="$LIBS -lcrypt"
++
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -25612,10 +25610,7 @@
+ return 0;
+ }
+ _ACEOF
+-if ac_fn_c_try_compile "$LINENO"; then :
+-
+-
+-$as_echo "#define HAVE_LIBCRYPT 1" >>confdefs.h
++if ac_fn_c_try_link "$LINENO"; then :
+
+ have_libcrypt=yes
+ have_crypt=yes
+@@ -25626,7 +25621,11 @@
+ $as_echo "$as_me: WARNING: crypt() is not available" >&2;}
+
+ fi
+-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++rm -f core conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++
++ LIBS="$old_LIBS"
++
+
+ fi
+ rm -f core conftest.err conftest.$ac_objext \
+@@ -25768,12 +25767,8 @@
+
+
+
+- old_CFLAGS="$CFLAGS"
+- old_CPPFLAGS="$CPPFLAGS"
+- old_LDFLAGS="$LDFLAGS"
+- CFLAGS="$CFLAGS "
+- CPPFLAGS="$CPPFLAGS "
+- LDFLAGS="$LDFLAGS $SELINUX_LIBS"
++ old_LIBS="$LIBS"
++ LIBS="$LIBS $SELINUX_LIBS"
+
+ # This function is missing in old libselinux 1.xx versions
+ for ac_func in security_get_initial_context
+@@ -25788,9 +25783,7 @@
+ done
+
+
+- CFLAGS="$old_CFLAGS"
+- CPPFLAGS="$old_CPPFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++ LIBS="$old_LIBS"
+
+
+ fi
+--- util-linux-2.37/Makefile.in
++++ util-linux-2.37/Makefile.in
+@@ -1,4 +1,4 @@
+-# Makefile.in generated by automake 1.16.2 from Makefile.am.
++# Makefile.in generated by automake 1.16.3 from Makefile.am.
+ # @configure_input@
+
+ # Copyright (C) 1994-2020 Free Software Foundation, Inc.
+@@ -4649,6 +4649,8 @@
+ GZIP_ENV = --best
+ DIST_ARCHIVES = $(distdir).tar.xz
+ DIST_TARGETS = dist-xz
++# Exists only to be overridden by the user if desired.
++AM_DISTCHECK_DVI_TARGET = dvi
+ distuninstallcheck_listfiles = find . -type f -print
+ am__distuninstallcheck_listfiles = $(distuninstallcheck_listfiles) \
+ | sed 's|^\./|$(prefix)/|' | grep -v '$(infodir)/dir$$'
+@@ -14854,7 +14856,7 @@
+ $(DISTCHECK_CONFIGURE_FLAGS) \
+ --srcdir=../.. --prefix="$$dc_install_base" \
+ && $(MAKE) $(AM_MAKEFLAGS) \
+- && $(MAKE) $(AM_MAKEFLAGS) dvi \
++ && $(MAKE) $(AM_MAKEFLAGS) $(AM_DISTCHECK_DVI_TARGET) \
+ && $(MAKE) $(AM_MAKEFLAGS) check \
+ && $(MAKE) $(AM_MAKEFLAGS) install \
+ && $(MAKE) $(AM_MAKEFLAGS) installcheck \
+@@ -14920,7 +14922,8 @@
+ done
+ install: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) install-recursive
+-install-exec: install-exec-recursive
++install-exec: $(BUILT_SOURCES)
++ $(MAKE) $(AM_MAKEFLAGS) install-exec-recursive
+ install-data: install-data-recursive
+ uninstall: uninstall-recursive
+
+@@ -16157,7 +16160,8 @@
+ uninstall-man8
+
+ .MAKE: $(am__recursive_targets) all check check-am install install-am \
+- install-data-am install-exec-am install-strip uninstall-am
++ install-data-am install-exec install-exec-am install-strip \
++ uninstall-am
+
+ .PHONY: $(am__recursive_targets) CTAGS GTAGS TAGS all all-am \
+ am--depfiles am--refresh check check-am check-local clean \
diff --git a/sys-apps/util-linux/files/util-linux-2.37-lcrypt_link_fix.patch b/sys-apps/util-linux/files/util-linux-2.37-lcrypt_link_fix.patch
new file mode 100644
index 000000000000..2da99b2841d6
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.37-lcrypt_link_fix.patch
@@ -0,0 +1,50 @@
+From 637cc045ee464909c261d6fa16c71ed15cd455e3 Mon Sep 17 00:00:00 2001
+From: Alex Xu <351006+Hello71@users.noreply.github.com>
+Date: Wed, 16 Jun 2021 13:58:25 +0000
+Subject: [PATCH] build-sys: Update configure.ac
+
+1. the test incorrectly used AC_COMPILE_IFELSE instead of
+ AC_LINK_IFELSE, defeating the purpose of checking -lcrypt.
+2. the test did not properly restore LIBS, causing later checks to all
+ fail if libcrypt wasn't found.
+3. HAVE_LIBCRYPT only controls whether to use -lcrypt, it is not
+ needed or used in any source files.
+
+[kzak@redhat.com: - improve commit message
+ - use UL_{SET,RESTORE}_FLAGS() rather than directly
+ modify $LIBS]
+
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5181d524c..939c6d2d3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -845,8 +845,8 @@ char *c = crypt("abc","pw");
+ have_libcrypt=no
+ have_crypt=yes
+ ],[
+- LIBS="$LIBS -lcrypt"
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
++ UL_SET_FLAGS([], [], [-lcrypt])
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #ifdef HAVE_CRYPT_H
+ #include <crypt.h>
+ #else
+@@ -856,12 +856,12 @@ char *c = crypt("abc","pw");
+ ]], [[
+ char *c = crypt("abc","pw");
+ ]])],[
+- AC_DEFINE([HAVE_LIBCRYPT], [1], [Do we need -lcrypt?])
+ have_libcrypt=yes
+ have_crypt=yes
+ ],[
+ AC_MSG_WARN([crypt() is not available])
+ ])
++ UL_RESTORE_FLAGS
+ ])
+ AM_CONDITIONAL([HAVE_LIBCRYPT], [test "x$have_libcrypt" = xyes])
+
diff --git a/sys-apps/util-linux/files/util-linux-2.37-lcrypt_use_LIBS.patch b/sys-apps/util-linux/files/util-linux-2.37-lcrypt_use_LIBS.patch
new file mode 100644
index 000000000000..2173195be612
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.37-lcrypt_use_LIBS.patch
@@ -0,0 +1,91 @@
+From 75cba8d5cdb2a0e84c23de26007feac977837a6f Mon Sep 17 00:00:00 2001
+From: Karel Zak <kzak@redhat.com>
+Date: Fri, 18 Jun 2021 17:21:13 +0200
+Subject: [PATCH] build-sys: use $LIBS rather than LDFLAGS
+
+Fixes: https://github.com/karelzak/util-linux/pull/1349
+Signed-off-by: Karel Zak <kzak@redhat.com>
+---
+ configure.ac | 8 ++++----
+ m4/ul.m4 | 29 +++++++++++------------------
+ 2 files changed, 15 insertions(+), 22 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 939c6d2d3..234cebc68 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -845,7 +845,7 @@ char *c = crypt("abc","pw");
+ have_libcrypt=no
+ have_crypt=yes
+ ],[
+- UL_SET_FLAGS([], [], [-lcrypt])
++ UL_SET_LIBS([-lcrypt])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #ifdef HAVE_CRYPT_H
+ #include <crypt.h>
+@@ -861,7 +861,7 @@ char *c = crypt("abc","pw");
+ ],[
+ AC_MSG_WARN([crypt() is not available])
+ ])
+- UL_RESTORE_FLAGS
++ UL_RESTORE_LIBS
+ ])
+ AM_CONDITIONAL([HAVE_LIBCRYPT], [test "x$have_libcrypt" = xyes])
+
+@@ -883,10 +883,10 @@ AS_IF([test "x$with_selinux" = xno], [
+ UL_PKG_STATIC([SELINUX_LIBS_STATIC], [libselinux])
+ AM_CONDITIONAL([HAVE_SELINUX], [true])
+
+- UL_SET_FLAGS([], [], [$SELINUX_LIBS])
++ UL_SET_LIBS([$SELINUX_LIBS])
+ # This function is missing in old libselinux 1.xx versions
+ AC_CHECK_FUNCS([security_get_initial_context])
+- UL_RESTORE_FLAGS
++ UL_RESTORE_LIBS
+ ])
+ ])
+ AC_SUBST([SELINUX_LIBS])
+diff --git a/m4/ul.m4 b/m4/ul.m4
+index 951db7371..724579462 100644
+--- a/m4/ul.m4
++++ b/m4/ul.m4
+@@ -67,28 +67,21 @@ AC_DEFUN([UL_SET_ARCH], [
+ ])
+
+
+-dnl UL_SET_FLAGS(CFLAGS, CPPFLAGS, LDFLAGS)
+-dnl
+-dnl Sets new global CFLAGS, CPPFLAGS and LDFLAG, the original
+-dnl setting could be restored by UL_RESTORE_FLAGS()
+-dnl
+-AC_DEFUN([UL_SET_FLAGS], [
+- old_CFLAGS="$CFLAGS"
+- old_CPPFLAGS="$CPPFLAGS"
+- old_LDFLAGS="$LDFLAGS"
+- CFLAGS="$CFLAGS $1"
+- CPPFLAGS="$CPPFLAGS $2"
+- LDFLAGS="$LDFLAGS $3"
++dnl UL_SET_LIBS(LIBS)
++dnl
++dnl Sets new global LIBS, the original setting could be restored by UL_RESTORE_LIBS()
++dnl
++AC_DEFUN([UL_SET_LIBS], [
++ old_LIBS="$LIBS"
++ LIBS="$LIBS $1"
+ ])
+
+-dnl UL_RESTORE_FLAGS()
++dnl UL_RESTORE_LIBS()
+ dnl
+-dnl Restores CFLAGS, CPPFLAGS and LDFLAG previously saved by UL_SET_FLAGS()
++dnl Restores LIBS previously saved by UL_SET_LIBS()
+ dnl
+-AC_DEFUN([UL_RESTORE_FLAGS], [
+- CFLAGS="$old_CFLAGS"
+- CPPFLAGS="$old_CPPFLAGS"
+- LDFLAGS="$old_LDFLAGS"
++AC_DEFUN([UL_RESTORE_LIBS], [
++ LIBS="$old_LIBS"
+ ])
+
+
diff --git a/sys-apps/util-linux/util-linux-2.37.ebuild b/sys-apps/util-linux/util-linux-2.37.ebuild
index 2b3ff76f988c..e12e94830621 100644
--- a/sys-apps/util-linux/util-linux-2.37.ebuild
+++ b/sys-apps/util-linux/util-linux-2.37.ebuild
@@ -90,6 +90,10 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
# https://github.com/karelzak/util-linux/pull/1329
"${FILESDIR}/${P}-ppc-nortas.patch"
+
+ "${FILESDIR}/${P}-lcrypt_link_fix.patch" # 801403
+ "${FILESDIR}/${P}-lcrypt_use_LIBS.patch" # 801403
+ "${FILESDIR}/${P}-avoid_autoreconf.patch" # 801403
)
rm_man() {