summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/ucon64/ucon64-2.2.1.ebuild')
-rw-r--r--games-util/ucon64/ucon64-2.2.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/games-util/ucon64/ucon64-2.2.1.ebuild b/games-util/ucon64/ucon64-2.2.1.ebuild
deleted file mode 100644
index 13ebde02c0b5..000000000000
--- a/games-util/ucon64/ucon64-2.2.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
-HOMEPAGE="http://ucon64.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
-S="${WORKDIR}/${P}-src/src"
-
-LICENSE="LGPL-2.1+ GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug usb zlib"
-
-RDEPEND="
- usb? ( virtual/libusb:0 )
- zlib? ( sys-libs/zlib:= )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-change-mem2-64bit.patch
- "${FILESDIR}"/${P}-respect-flags.patch
- "${FILESDIR}"/${P}-zlib.patch
-)
-
-src_prepare() {
- default
-
- sed "/discmage.so/s|.* \"|\"${EPREFIX}/usr/$(get_libdir)/${PN}/|" \
- -i ucon64_misc.c || die
-}
-
-src_configure() {
- local econfargs=(
- $(use_enable debug)
- $(use_with usb libusb)
- $(use_with zlib)
- --enable-ppdev
- --with-libcd64
- --with-libdiscmage
- )
- econf "${econfargs[@]}"
-
- tc-export AR CC LD # for libcd64 with respect-flags.patch
-}
-
-src_install() {
- dobin ucon64
-
- exeinto /usr/$(get_libdir)/${PN}
- doexe libdiscmage/discmage.so
-
- docinto html
- dodoc -r ../images ../{changes,developers,faq,hardware,readme}.html
-}
-
-pkg_postinst() {
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "Be sure to check ~/.ucon64rc for some options after"
- elog "you've run uCON64 for the first time."
- fi
-}