summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/ucon64/Manifest1
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch23
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch35
-rw-r--r--games-util/ucon64/files/ucon64-2.2.1-zlib.patch26
-rw-r--r--games-util/ucon64/ucon64-2.2.1.ebuild65
5 files changed, 0 insertions, 150 deletions
diff --git a/games-util/ucon64/Manifest b/games-util/ucon64/Manifest
index 1128342e97df..d31bb6ad971d 100644
--- a/games-util/ucon64/Manifest
+++ b/games-util/ucon64/Manifest
@@ -1,2 +1 @@
-DIST ucon64-2.2.1-src.tar.gz 1476080 BLAKE2B 8f7010bde2c7306f6a76dec4ce5e31975c286801e6504bf8bc99287bd7adc4ab10331a8cab308fed83ece9e13bdb01327f6d3439eba776038dbb19eb2b72cf70 SHA512 34453399151e5ed256fdcf387b9d32a052718b264e51b99a2be251b90589337d13cd317f8d1aa7d3c8e39c8e407b22797d4608ec6d14b99c8673ec74f349f6c2
DIST ucon64-2.2.2-src.tar.gz 1481087 BLAKE2B 3ae3d09f4ea186d4e64d712bf0e3036ca79b7e87ba9a9b165fdcee2f0e24ac1dd00a5da9653a404850e8bc1f85cd6b26e0d03615e60090709d9b792c3db07e8e SHA512 21e403e6de64c0a76de32032fbafea75f53a96b88b343220cdc8d62ef3bdec252764cacb9bbf98a910477ba451bc05aee8c9f91024b9e5d3149f7ead20d426b5
diff --git a/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch b/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch
deleted file mode 100644
index d07a18fdd8f0..000000000000
--- a/games-util/ucon64/files/ucon64-2.2.1-change-mem2-64bit.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Fix crash on 64bit platforms in change_mem2()
-https://bugs.gentoo.org/753950
-
-From upstream:
-https://sourceforge.net/p/ucon64/svn/2821/
---- a/libdiscmage/misc.c
-+++ b/libdiscmage/misc.c
-@@ -1875,5 +1875,5 @@
- if (strpos == pos_1st_esc)
- setindex = 0; // reset argument pointer
-- if (pos_1st_esc == (unsigned int) -1)
-+ if (pos_1st_esc == (size_t) -1)
- pos_1st_esc = strpos;
-
---- a/misc/misc.c
-+++ b/misc/misc.c
-@@ -502,5 +502,5 @@
- if (strpos == pos_1st_esc)
- setindex = 0; // reset argument pointer
-- if (pos_1st_esc == (unsigned int) -1)
-+ if (pos_1st_esc == (size_t) -1)
- pos_1st_esc = strpos;
-
diff --git a/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch b/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch
deleted file mode 100644
index c1c9ed6f78da..000000000000
--- a/games-util/ucon64/files/ucon64-2.2.1-respect-flags.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Respect *FLAGS and toolchain variables in Makefiles where missing.
---- a/Makefile
-+++ b/Makefile
-@@ -12,3 +12,3 @@
- CFLAGS+=-I. -Wall -W -Wno-implicit-fallthrough -Wno-format-truncation \
---Wno-stringop-overflow -O3 -fsigned-char
-+-Wno-stringop-overflow -fsigned-char
- # Enable -Wstringop-overflow[=type] when it is no longer a broken, partial
-@@ -19,3 +19,2 @@
- # ld: warning: option -s is obsolete and being ignored
--LDFLAGS+=-s
- endif
---- a/backup/libcd64/Makefile
-+++ b/backup/libcd64/Makefile
-@@ -1,2 +1 @@
--CC=gcc
-
-@@ -7,3 +6,2 @@
- else
--CFLAGS+=-O6 -funroll-loops -fexpensive-optimizations
- endif
-@@ -181,4 +179,4 @@
- else
-- ld -r $^ $(LIBS) -o $*.o
-- ar crs $@ $*.o
-+ $(LD) -r $^ $(LIBS) -o $*.o
-+ $(AR) crs $@ $*.o
- endif
---- a/libdiscmage/Makefile.in
-+++ b/libdiscmage/Makefile.in
-@@ -33,3 +33,2 @@
- # /usr/bin/libtool: -static not specified, -s invalid
--LDFLAGS+=-s
- endif
-
diff --git a/games-util/ucon64/files/ucon64-2.2.1-zlib.patch b/games-util/ucon64/files/ucon64-2.2.1-zlib.patch
deleted file mode 100644
index a618c3bce75a..000000000000
--- a/games-util/ucon64/files/ucon64-2.2.1-zlib.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix undefined macro issue when compiling with zlib.
-https://bugs.gentoo.org/753950
-
-From upstream:
-https://sourceforge.net/p/ucon64/svn/2817/
-https://sourceforge.net/p/ucon64/svn/2819/
---- a/libdiscmage/ioapi.h
-+++ b/libdiscmage/ioapi.h
-@@ -35,4 +35,7 @@
- extern "C" {
- #endif
-+#ifndef OF
-+#define OF(x) x
-+#endif
-
- typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
---- a/misc/ioapi.h
-+++ b/misc/ioapi.h
-@@ -35,4 +35,7 @@
- extern "C" {
- #endif
-+#ifndef OF
-+#define OF(x) x
-+#endif
-
- typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
diff --git a/games-util/ucon64/ucon64-2.2.1.ebuild b/games-util/ucon64/ucon64-2.2.1.ebuild
deleted file mode 100644
index 13ebde02c0b5..000000000000
--- a/games-util/ucon64/ucon64-2.2.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
-HOMEPAGE="http://ucon64.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
-S="${WORKDIR}/${P}-src/src"
-
-LICENSE="LGPL-2.1+ GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug usb zlib"
-
-RDEPEND="
- usb? ( virtual/libusb:0 )
- zlib? ( sys-libs/zlib:= )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-change-mem2-64bit.patch
- "${FILESDIR}"/${P}-respect-flags.patch
- "${FILESDIR}"/${P}-zlib.patch
-)
-
-src_prepare() {
- default
-
- sed "/discmage.so/s|.* \"|\"${EPREFIX}/usr/$(get_libdir)/${PN}/|" \
- -i ucon64_misc.c || die
-}
-
-src_configure() {
- local econfargs=(
- $(use_enable debug)
- $(use_with usb libusb)
- $(use_with zlib)
- --enable-ppdev
- --with-libcd64
- --with-libdiscmage
- )
- econf "${econfargs[@]}"
-
- tc-export AR CC LD # for libcd64 with respect-flags.patch
-}
-
-src_install() {
- dobin ucon64
-
- exeinto /usr/$(get_libdir)/${PN}
- doexe libdiscmage/discmage.so
-
- docinto html
- dodoc -r ../images ../{changes,developers,faq,hardware,readme}.html
-}
-
-pkg_postinst() {
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "Be sure to check ~/.ucon64rc for some options after"
- elog "you've run uCON64 for the first time."
- fi
-}