diff options
author | Arthur Zamarin <arthurzam@gentoo.org> | 2024-01-19 11:59:09 +0200 |
---|---|---|
committer | Arthur Zamarin <arthurzam@gentoo.org> | 2024-01-19 11:59:09 +0200 |
commit | c488f5c056a8d6f867b58bd5b78fea2f46c43f66 (patch) | |
tree | 32beee354a216495d771edc00d85c11608d89dbb | |
parent | ci: add pypy3.10 (diff) | |
download | snakeoil-c488f5c056a8d6f867b58bd5b78fea2f46c43f66.tar.gz snakeoil-c488f5c056a8d6f867b58bd5b78fea2f46c43f66.tar.bz2 snakeoil-c488f5c056a8d6f867b58bd5b78fea2f46c43f66.zip |
update python version in various places
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r-- | LICENSE | 2 | ||||
-rw-r--r-- | README.rst | 6 | ||||
-rw-r--r-- | tox.ini | 24 |
3 files changed, 14 insertions, 18 deletions
@@ -1,4 +1,4 @@ -Copyright (c) 2007-2021, snakeoil contributors +Copyright (c) 2007-2024, snakeoil contributors All rights reserved. Redistribution and use in source and binary forms, with or without @@ -21,14 +21,14 @@ Installing from git:: Installing from a tarball:: - python setup.py install + pip install . Tests ===== -A standalone test runner is integrated in setup.py; to run, just execute:: +Normal pytest is used, just execute:: - python setup.py test + pytest Using tox for all supported python versions:: @@ -1,25 +1,21 @@ [tox] envlist = py310, py311, py312, pypy3 +skip_missing_interpreters = True +isolated_build = True + [testenv] # force latest virtualenv/pip download = true -deps = -rrequirements/tox.txt +extras = + test commands = - pytest --cov {posargs:-v} + pytest {posargs} # build docs [testenv:docs] skip_install = true -deps = - -rrequirements/dev.txt - -rrequirements/docs.txt -commands = - python setup.py build_docs - -# build dist files -[testenv:dist] -skip_install = true -deps = -rrequirements/dist.txt +extras = + doc commands = - python setup.py sdist - python setup.py bdist_wheel + make man + make html |