aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LICENSE2
-rw-r--r--README.rst6
-rw-r--r--tox.ini24
3 files changed, 14 insertions, 18 deletions
diff --git a/LICENSE b/LICENSE
index c24d27b9..019d5650 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-Copyright (c) 2007-2021, snakeoil contributors
+Copyright (c) 2007-2024, snakeoil contributors
All rights reserved.
Redistribution and use in source and binary forms, with or without
diff --git a/README.rst b/README.rst
index 570db727..6cc958e9 100644
--- a/README.rst
+++ b/README.rst
@@ -21,14 +21,14 @@ Installing from git::
Installing from a tarball::
- python setup.py install
+ pip install .
Tests
=====
-A standalone test runner is integrated in setup.py; to run, just execute::
+Normal pytest is used, just execute::
- python setup.py test
+ pytest
Using tox for all supported python versions::
diff --git a/tox.ini b/tox.ini
index 59feefc5..cd763aaf 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,25 +1,21 @@
[tox]
envlist = py310, py311, py312, pypy3
+skip_missing_interpreters = True
+isolated_build = True
+
[testenv]
# force latest virtualenv/pip
download = true
-deps = -rrequirements/tox.txt
+extras =
+ test
commands =
- pytest --cov {posargs:-v}
+ pytest {posargs}
# build docs
[testenv:docs]
skip_install = true
-deps =
- -rrequirements/dev.txt
- -rrequirements/docs.txt
-commands =
- python setup.py build_docs
-
-# build dist files
-[testenv:dist]
-skip_install = true
-deps = -rrequirements/dist.txt
+extras =
+ doc
commands =
- python setup.py sdist
- python setup.py bdist_wheel
+ make man
+ make html